Bug 1241555 - fakechroot isn't multilib
Summary: fakechroot isn't multilib
Keywords:
Status: ASSIGNED
Alias: None
Product: Fedora
Classification: Fedora
Component: fakechroot
Version: 30
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ---
Assignee: Mosaab Alzoubi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-09 13:24 UTC by Loïc Yhuel
Modified: 2019-10-27 02:20 UTC (History)
3 users (show)

Fixed In Version: fakechroot-2.20.1-1.fc31
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-27 01:29:26 UTC


Attachments (Terms of Use)

Description Loïc Yhuel 2015-07-09 13:24:18 UTC
There are two issues preventing to use fakechroot on 32 bit programs on a 64 bit distribution:
 - fakechroot-libs.i686 isn't in the x86_64 repo
 - fakechroot sets LD_LIBRARY_PATH=/usr/lib64/fakechroot, it should be /usr/lib64/fakechroot:/usr/lib/fakechroot, so ld.so will pick up the correct libfakechroot.so depending on the program

Comment 1 Fedora Admin XMLRPC Client 2016-02-26 17:43:53 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Fedora Admin XMLRPC Client 2016-03-01 20:36:41 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Jan Kurik 2016-07-26 04:47:55 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 4 Sergio Monteiro Basto 2016-10-06 18:30:39 UTC
Hi, 

fakechroot-libs is already an multilib in F24 ,

https://pagure.io/mash/issue/5
https://pagure.io/pungi/issue/276
https://pagure.io/pungi-fedora/issue/21

dnf repoquery  --releasever=24 "fakeroot*"

fakeroot-0:1.20.2-3.fc23.x86_64
fakeroot-0:1.20.2-4.fc24.x86_64
fakeroot-libs-0:1.20.2-3.fc23.x86_64
-->    fakeroot-libs-0:1.20.2-4.fc24.i686
fakeroot-libs-0:1.20.2-4.fc24.x86_64


Can you check if this bug is fixed ? please 

Thanks.

Comment 5 Loïc Yhuel 2016-10-06 19:48:36 UTC
(In reply to Sergio Monteiro Basto from comment #4)
> dnf repoquery  --releasever=24 "fakeroot*"
You tested fakeroot, not fakechroot.
The first one was fixed, the second one isn't (the two issues in comment #1 are still present).

Comment 6 Sergio Monteiro Basto 2016-10-06 21:17:10 UTC
ah, OK, I added a new ticket in mash [1] 

Thanks.


[1] https://pagure.io/mash/issue/9

Comment 7 Sergio Monteiro Basto 2017-03-01 22:58:29 UTC
(In reply to Sergio Monteiro Basto from comment #6)
> ah, OK, I added a new ticket in mash [1] 
> 
> Thanks.
> 
> 
> [1] https://pagure.io/mash/issue/9

ticket closed with : "@sergiomb fakechroot-libs is added to multilib in rawhide and f26. its not needed for f25 since we are not making any composes out of f25." 

Now, we just need verify that we have this bug fixed or if we still need more changes . 
Thanks

Comment 8 Loïc Yhuel 2017-03-02 06:40:49 UTC
# dnf repoquery "fakechroot*"
fakechroot-0:2.18-1.fc25.x86_64
fakechroot-0:2.19-1.fc25.x86_64
fakechroot-debuginfo-0:2.18-1.fc25.x86_64
fakechroot-debuginfo-0:2.19-1.fc25.x86_64
fakechroot-libs-0:2.18-1.fc25.x86_64
fakechroot-libs-0:2.19-1.fc25.x86_64

So the i686 package still isn't in the F25 repo, so a change is still needed.
On Rawhide the i686 package is in the repo.

There is still the library path issue in /usr/bin/fakechroot :
fakechroot_paths=/usr/lib64/fakechroot
It needs to be fakechroot_paths=/usr/lib64/fakechroot:/usr/lib/fakechroot, to be able to load the 32-bit libs.

Comment 9 Sergio Monteiro Basto 2017-03-10 01:10:40 UTC
dnf-3 --disablerepo='*' --releasever=26 --enablerepo=fedora  repoquery "fakechroot*"
fakechroot-0:2.18-1.fc24.x86_64
fakechroot-0:2.19-1.fc26.x86_64
fakechroot-libs-0:2.18-1.fc24.x86_64
fakechroot-libs-0:2.19-1.fc26.i686
fakechroot-libs-0:2.19-1.fc26.x86_64

(In reply to Loïc Yhuel from comment #8)
> So the i686 package still isn't in the F25 repo, so a change is still needed.

yes only in F26+ we got multilib like I wrote in previous comment. 

> On Rawhide the i686 package is in the repo.
> 

yes 

> There is still the library path issue in /usr/bin/fakechroot :
> fakechroot_paths=/usr/lib64/fakechroot
> It needs to be fakechroot_paths=/usr/lib64/fakechroot:/usr/lib/fakechroot,
> to be able to load the 32-bit libs.

hum it is a bug ? , shouldn't be reported upstream fakechroot develelopment ? 
what you suggest ?

Comment 10 Loïc Yhuel 2017-03-10 03:26:18 UTC
(In reply to Sergio Monteiro Basto from comment #9)
> yes only in F26+ we got multilib like I wrote in previous comment. 
I still don't understand the "not needed" comment.
Is it too late to change it for F25 ?

> > There is still the library path issue in /usr/bin/fakechroot :
> > fakechroot_paths=/usr/lib64/fakechroot
> > It needs to be fakechroot_paths=/usr/lib64/fakechroot:/usr/lib/fakechroot,
> > to be able to load the 32-bit libs.
> 
> hum it is a bug ? , shouldn't be reported upstream fakechroot develelopment
> ? 
> what you suggest ?

It's a bug since the user may want to run 32-bit programs with fakechroot, even on a 64-bit distribution.

The paths can be set with the --with-libpath configure argument, which is "$libdir/$PACKAGE_NAME" by default.
Upstream has no way to know where the 32-bit libdir is on a 64-bit build, since it depends on the distribution (/usr/lib on Fedora, /usr/lib32 on Archlinux, /usr/lib/<triplet> on Debian, ...).

Comment 11 Sergio Monteiro Basto 2017-03-10 05:07:40 UTC
(In reply to Loïc Yhuel from comment #10)
> (In reply to Sergio Monteiro Basto from comment #9)
> > yes only in F26+ we got multilib like I wrote in previous comment. 
> I still don't understand the "not needed" comment.
> Is it too late to change it for F25 ?

yes I think it is too late , but you may ask in https://pagure.io/pungi-fedora/issue/93 , I mean you may ask directly why is not need and if is too late instead I intermediate .

> > > There is still the library path issue in /usr/bin/fakechroot :
> > > fakechroot_paths=/usr/lib64/fakechroot
> > > It needs to be fakechroot_paths=/usr/lib64/fakechroot:/usr/lib/fakechroot,
> > > to be able to load the 32-bit libs.
> > 
> > hum it is a bug ? , shouldn't be reported upstream fakechroot develelopment
> > ? 
> > what you suggest ?
> 
> It's a bug since the user may want to run 32-bit programs with fakechroot,
> even on a 64-bit distribution.
> 
> The paths can be set with the --with-libpath configure argument, which is
> "$libdir/$PACKAGE_NAME" by default.
> Upstream has no way to know where the 32-bit libdir is on a 64-bit build,
> since it depends on the distribution (/usr/lib on Fedora, /usr/lib32 on
> Archlinux, /usr/lib/<triplet> on Debian, ...).

ah I will check it , when got some time ... , patches for fakechroot.spec are welcome

Comment 12 Fedora End Of Life 2017-11-16 19:53:57 UTC
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 13 Sergio Monteiro Basto 2017-11-16 21:12:08 UTC
(In reply to Sergio Monteiro Basto from comment #11)
I haven't check this yet

Comment 14 Ben Cotton 2018-11-27 18:12:43 UTC
This message is a reminder that Fedora 27 is nearing its end of life.
On 2018-Nov-30  Fedora will stop maintaining and issuing updates for
Fedora 27. It is Fedora's policy to close all bug reports from releases
that are no longer maintained. At that time this bug will be closed as
EOL if it remains open with a Fedora  'version' of '27'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 27 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 15 Ben Cotton 2019-02-19 17:12:22 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 30 development cycle.
Changing version to '30.

Comment 16 Fedora Update System 2019-10-18 03:04:52 UTC
FEDORA-2019-dc5bb36e39 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-dc5bb36e39

Comment 17 Sergio Monteiro Basto 2019-10-18 03:29:22 UTC
(In reply to Loïc Yhuel from comment #10)
> (In reply to Sergio Monteiro Basto from comment #9) 
> > > There is still the library path issue in /usr/bin/fakechroot :
> > > fakechroot_paths=/usr/lib64/fakechroot
> > > It needs to be fakechroot_paths=/usr/lib64/fakechroot:/usr/lib/fakechroot,
> > > to be able to load the 32-bit libs.
> > 
> > hum it is a bug ? , shouldn't be reported upstream fakechroot develelopment
> > ? 
> > what you suggest ?
> 
> It's a bug since the user may want to run 32-bit programs with fakechroot,
> even on a 64-bit distribution.
> 
> The paths can be set with the --with-libpath configure argument, which is
> "$libdir/$PACKAGE_NAME" by default.
> Upstream has no way to know where the 32-bit libdir is on a 64-bit build,
> since it depends on the distribution (/usr/lib on Fedora, /usr/lib32 on
> Archlinux, /usr/lib/<triplet> on Debian, ...).

is not fixed isn't it ? , can you do a patch to spec file ? 

Thanks

Comment 18 Fedora Update System 2019-10-18 17:35:54 UTC
fakechroot-2.20.1-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-dc5bb36e39

Comment 19 Fedora Update System 2019-10-27 01:29:26 UTC
fakechroot-2.20.1-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.