Bug 1241742 - ERROR openstack Connection to neutron failed: ('Connection aborted.', BadStatusLine("''",)
Summary: ERROR openstack Connection to neutron failed: ('Connection aborted.', BadS...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: Director
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: Director
Assignee: Jay Dobies
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-10 01:40 UTC by wes hayutin
Modified: 2015-08-05 13:59 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:59:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description wes hayutin 2015-07-10 01:40:35 UTC
Description of problem:

[2015-07-09 21:32:19,029] DEBUG    neutronclient.client 
REQ: curl -i http://172.16.23.10:9696//v2.0/agents.json -X GET -H "User-Agent: python-neutronclient" -H "X-Auth-Token: 6f2978407df340ce9b7b5e66e05373b9"

[2015-07-09 21:32:19,046] DEBUG    neutronclient.client throwing ConnectionFailed : ('Connection aborted.', BadStatusLine("''",))
[2015-07-09 21:32:19,046] ERROR    openstack Connection to neutron failed: ('Connection aborted.', BadStatusLine("''",))
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/cliff/app.py", line 295, in run_subcommand
    result = cmd.run(parsed_args)
  File "/usr/lib/python2.7/site-packages/cliff/command.py", line 53, in run
    self.take_action(parsed_args)
  File "/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py", line 829, in take_action
    self._deploy_postconfig(stack, parsed_args)
  File "/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py", line 624, in _deploy_postconfig
    neutron_agents = neutron_client.list_agents()
  File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 102, in with_params
    ret = self.function(instance, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 1177, in list_agents
    return self.get(self.agents_path, params=_params)
  File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 293, in get
    headers=headers, params=params)
  File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 270, in retry_request
    headers=headers, params=params)
  File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 200, in do_request
    content_type=self.content_type())
  File "/usr/lib/python2.7/site-packages/neutronclient/client.py", line 170, in do_request
    **kwargs)
  File "/usr/lib/python2.7/site-packages/neutronclient/client.py", line 106, in _cs_request
    raise exceptions.ConnectionFailed(reason=e)
ConnectionFailed: Connection to neutron failed: ('Connection aborted.', BadStatusLine("''",))
[2015-07-09 21:32:19,094] DEBUG    openstackclient.shell clean_up DeployOvercloud
[2015-07-09 21:32:19,094] DEBUG    openstackclient.shell got an error: Connection to neutron failed: ('Connection aborted.', BadStatusLine("''",))

Comment 4 chris alfonso 2015-07-13 13:10:37 UTC
Attila, Can you provide more information here, please.

Comment 5 chris alfonso 2015-07-13 17:38:35 UTC
We think this might be fixed

Comment 6 Attila Darazs 2015-07-14 14:23:10 UTC
I don't see the problem in CI now, so removing the needinfo from my side.

Comment 8 Leonid Natapov 2015-07-21 11:12:46 UTC
unable to reproduce in the last several puddles.

Comment 10 errata-xmlrpc 2015-08-05 13:59:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.