Bug 1241776 - [Data Tiering]: HOT Files get demoted from hot tier
Summary: [Data Tiering]: HOT Files get demoted from hot tier
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.2
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1240970
Blocks: 1260923
TreeView+ depends on / blocked
 
Reported: 2015-07-10 05:45 UTC by Joseph Elwin Fernandes
Modified: 2016-06-20 00:01 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1240970
Environment:
Last Closed: 2015-07-30 09:50:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Joseph Elwin Fernandes 2015-07-10 05:45:20 UTC
+++ This bug was initially created as a clone of Bug #1240970 +++

Description of problem:

Files which are HOT are getting demoted from the hot tier.

Version-Release number of selected component (if applicable):
master

How reproducible:

1) create a dist-rep volume 1x2
2) start the volume 
3) switch off the performance xlator (optional)
4) attach a dist-rep tier 1x2
5) fuse mount the volume
6) create a file : touch file1.
7) heat up the file : for i in {1..10}; do touch file1; done
8) wait for the default promotion/demotion frequency secs i.e sleep 120
9) the file demoted! [shouldn't demote!!]
10) Heat up the file again: for i in {1..10}; do touch file1; done
11) wait for the default promotion/demotion frequency secs i.e sleep 120
12) the file is promoted [as expected]
13) heat up the file : for i in {1..10}; do touch file1; done
14) wait for the default promotion/demotion frequency secs i.e sleep 120
15) the file demoted! [shouldn't demote!!]


Actual results:
HOT file Demoted!

Expected results:
HOT File shouldn't demote


Additional info:

--- Additional comment from Anand Avati on 2015-07-08 05:25:31 EDT ---

REVIEW: http://review.gluster.org/11577 (libgfdb/sql: Fixing broken query of find_unchanged) posted (#1) for review on master by Joseph Fernandes

--- Additional comment from Joseph Elwin Fernandes on 2015-07-08 05:29:36 EDT ---

Comment 1 Anand Avati 2015-07-10 05:51:53 UTC
REVIEW: http://review.gluster.org/11608 (libgfdb/sql: Fixing broken query of find_unchanged) posted (#1) for review on release-3.7 by Joseph Fernandes

Comment 2 Kaushal 2015-07-30 09:50:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.