Bug 1241825 - Custom building options are not saved
Summary: Custom building options are not saved
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: latexila
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thibault North
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-10 07:50 UTC by Jean-Christophe Baptiste
Modified: 2016-01-17 07:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-17 07:24:30 UTC


Attachments (Terms of Use)

Description Jean-Christophe Baptiste 2015-07-10 07:50:09 UTC
Description of problem:

In Build > Manage Build Tools,there is the possibility to modify building settings, by changing default ones or creating new ones.

It works but all settings are lost after closing and then reopening the application. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

1. Create new or modify existing build settings
2. It works as expected, a new entry appears in the build menu along with a new icon in the toolbar
3. Close Latexila
4. Launch Latexila again : everything is gone : no menu entry, no icon and no setting in the tool

Expected results:

Of course, Latexila should save settings.
It makes it pretty unusable, as for instance I need to compile all my documents with -shell-escape option.

Comment 1 Jean-Christophe Baptiste 2015-07-13 20:09:05 UTC
I solved the issue by created the ~/.config/latexila folder that was missing.

After that and modifying build tools, a build_tools.xml file was created by the application.
Now all settings are correctly saved inside.

So basically there is an issue with the ~/.config/latexila not being created at launch time, if missing (after a fresh install).

Comment 2 Sébastien Wilmet 2015-08-18 08:19:50 UTC
Thanks for the bug report. I can reproduce the bug, I'll fix it ASAP and release a new 3.16.x version, since it's a quite annoying bug.

Sorry to not have seen the bug report earlier, usually I receive mail notifications when comments are posted on my blog, but it was not the case. And I'm not subscribed to the Fedora bugzilla.

Comment 3 Sébastien Wilmet 2015-08-18 11:24:28 UTC
Fixed:
https://git.gnome.org/browse/latexila/commit/?id=181f3e89268dd5c72a1a7046e1fd213aabf4ff1b

It's backported to the 3.16 version, and a new release is available (3.16.2).

Comment 4 Jean-Christophe Baptiste 2016-01-17 07:24:30 UTC
Thanks a lot!


Note You need to log in before you can comment on or make changes to this bug.