Bug 1241841 - gf_msg_callingfn does not log the callers of the function in which it is called
Summary: gf_msg_callingfn does not log the callers of the function in which it is called
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: logging
Version: 3.7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard:
Depends On: 1238952
Blocks: 1241830
TreeView+ depends on / blocked
 
Reported: 2015-07-10 08:32 UTC by Nithya Balachandran
Modified: 2015-07-30 09:50 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1238952
Environment:
Last Closed: 2015-07-30 09:50:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nithya Balachandran 2015-07-10 08:32:56 UTC
+++ This bug was initially created as a clone of Bug #1238952 +++

Description of problem:

Outout of gf_msg_callingfn is as follows:


[glusterd-op-sm.c:249:glusterd_get_txn_opinfo] (--> 0-management: Unable to get       transaction opinfo for transaction ID : 4ad5f5bb-8a83-4c06-9883-c3ed572ad77d [Permission denied]


It does not log the callers of the function.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-07-03 05:45:34 EDT ---

REVIEW: http://review.gluster.org/11521 (logging: Fixed incorrect buffer size) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Anand Avati on 2015-07-07 00:47:41 EDT ---

REVIEW: http://review.gluster.org/11521 (logging: Fixed incorrect buffer size) posted (#2) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Anand Avati on 2015-07-07 23:53:10 EDT ---

REVIEW: http://review.gluster.org/11521 (logging: Fixed incorrect buffer size) posted (#3) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Anand Avati on 2015-07-10 00:23:24 EDT ---

REVIEW: http://review.gluster.org/11521 (logging: Fixed incorrect buffer size) posted (#4) for review on master by N Balachandran (nbalacha@redhat.com)

Comment 1 Anand Avati 2015-07-10 08:34:34 UTC
REVIEW: http://review.gluster.org/11615 (logging: Fixed incorrect buffer size) posted (#1) for review on release-3.7 by N Balachandran (nbalacha@redhat.com)

Comment 2 Kaushal 2015-07-30 09:50:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.