Bug 1241848 - During deploy got the the message: Failed to validate: The specified reference "ControllerOvercloudServicesDeployment_Step6" (in ExtraConfig) is incorrect.
Summary: During deploy got the the message: Failed to validate: The specified referenc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: Director
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: Director
Assignee: Giulio Fidente
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-10 08:45 UTC by Adriano Petrich
Modified: 2015-08-05 13:59 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-heat-templates-0.8.6-34.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:59:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
debug of the overcloud deploy (892.60 KB, text/plain)
2015-07-10 08:45 UTC, Adriano Petrich
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Adriano Petrich 2015-07-10 08:45:43 UTC
Created attachment 1050623 [details]
debug of the overcloud deploy

Description of problem:

virt osp-director overcloud deployment fails w/

ERROR: openstack ERROR: Failed to validate: The specified reference "ControllerOvercloudServicesDeployment_Step6" (in ExtraConfig) is incorrect.
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/cliff/app.py", line 295, in run_subcommand
    result = cmd.run(parsed_args)
  File "/usr/lib/python2.7/site-packages/cliff/command.py", line 53, in run
    self.take_action(parsed_args)
  File "/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py", line 818, in take_action
    self._deploy_tuskar(stack, parsed_args)
  File "/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py", line 513, in _deploy_tuskar
    self._heat_deploy(stack, overcloud_yaml, parameters, environments)
  File "/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py", line 388, in _heat_deploy
    orchestration_client.stacks.create(**stack_args)
  File "/usr/lib/python2.7/site-packages/heatclient/v1/stacks.py", line 134, in create
    data=kwargs, headers=headers)
  File "/usr/lib/python2.7/site-packages/heatclient/common/http.py", line 265, in json_request
    resp = self._http_request(url, method, **kwargs)
  File "/usr/lib/python2.7/site-packages/heatclient/common/http.py", line 220, in _http_request
    raise exc.from_response(resp)
HTTPBadRequest: ERROR: Failed to validate: The specified reference "ControllerOvercloudServicesDeployment_Step6" (in ExtraConfig) is incorrect.
DEBUG: openstackclient.shell clean_up DeployOvercloud
DEBUG: openstackclient.shell got an error: ERROR: Failed to validate: The specified reference "ControllerOvercloudServicesDeployment_Step6" (in ExtraConfig) is incorrect.
ERROR: openstackclient.shell Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/openstackclient/shell.py", line 176, in run
    return super(OpenStackShell, self).run(argv)
  File "/usr/lib/python2.7/site-packages/cliff/app.py", line 230, in run
    result = self.run_subcommand(remainder)
  File "/usr/lib/python2.7/site-packages/cliff/app.py", line 295, in run_subcommand
    result = cmd.run(parsed_args)
  File "/usr/lib/python2.7/site-packages/cliff/command.py", line 53, in run
    self.take_action(parsed_args)
  File "/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py", line 818, in take_action
    self._deploy_tuskar(stack, parsed_args)
  File "/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py", line 513, in _deploy_tuskar
    self._heat_deploy(stack, overcloud_yaml, parameters, environments)
  File "/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py", line 388, in _heat_deploy
    orchestration_client.stacks.create(**stack_args)
  File "/usr/lib/python2.7/site-packages/heatclient/v1/stacks.py", line 134, in create
    data=kwargs, headers=headers)
  File "/usr/lib/python2.7/site-packages/heatclient/common/http.py", line 265, in json_request
    resp = self._http_request(url, method, **kwargs)
  File "/usr/lib/python2.7/site-packages/heatclient/common/http.py", line 220, in _http_request
    raise exc.from_response(resp)
HTTPBadRequest: ERROR: Failed to validate: The specified reference "ControllerOvercloudServicesDeployment_Step6" (in ExtraConfig) is incorrect.

Version-Release number of selected component (if applicable):

Poodle used:
 http://ayanami.bos.devel.redhat.com/poodles/rhos-devel-ci/7.0-director/latest/RHOS-7-director/x86_64/os/

How reproducible:
very. all CI tasks are failing on that.

Comment 4 Alexander Chuzhoy 2015-07-21 18:21:52 UTC
Verified:
Environment:
instack-undercloud-2.1.2-21.el7ost.noarch

Don't reproduce the issue. Able to deploy the overcloud.

Comment 6 errata-xmlrpc 2015-08-05 13:59:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.