Bug 1241863 - pypolicyd-spf IP address/network parse error
Summary: pypolicyd-spf IP address/network parse error
Status: CLOSED DUPLICATE of bug 1230373
Alias: None
Product: Fedora
Classification: Fedora
Component: pypolicyd-spf
Version: 22
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Bojan Smojver
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-10 09:28 UTC by Vladislav Grigoryev
Modified: 2015-07-10 09:36 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-07-10 09:36:59 UTC


Attachments (Terms of Use)

Description Vladislav Grigoryev 2015-07-10 09:28:40 UTC
Description of problem:
postfix/smtpd[26506]: connect from mail.citrus-project.ru[46.146.242.177]
policyd-spf[2599]: ERROR: 127.0.0.0/8 in skip_addresses not IP network.  Message: '46.146.242.177' does not appear to be an IPv4 or IPv6 address. Did you pass in a bytes (str in Python 2) instead of a unicode object?. Aborting whitelist processing.
policyd-spf[2599]: Traceback (most recent call last):
policyd-spf[2599]: File "/usr/libexec/postfix/policyd-spf", line 680, in <module>
policyd-spf[2599]: instance_dict, configData, peruser)
policyd-spf[2599]: File "/usr/libexec/postfix/policyd-spf", line 413, in _spfcheck
policyd-spf[2599]: res = spf.check2(ip, helo_fake_sender, helo, querytime=configData.get('Lookup_Time'))
policyd-spf[2599]: File "/usr/lib/python2.7/site-packages/spf.py", line 297, in check2
policyd-spf[2599]: receiver=receiver,timeout=timeout,verbose=verbose,querytime=querytime).check()
policyd-spf[2599]: File "/usr/lib/python2.7/site-packages/spf.py", line 378, in __init__
policyd-spf[2599]: self.set_ip(i)
policyd-spf[2599]: File "/usr/lib/python2.7/site-packages/spf.py", line 405, in set_ip
policyd-spf[2599]: self.ipaddr = ipaddress.ip_address(i)
policyd-spf[2599]: File "/usr/lib/python2.7/site-packages/ipaddress.py", line 115, in ip_address
policyd-spf[2599]: ' a unicode object?' % address)
policyd-spf[2599]: AddressValueError: '46.146.242.177' does not appear to be an IPv4 or IPv6 address. Did you pass in a bytes (str in Python 2) instead of a unicode object?
postfix/spawn[32473]: warning: command /usr/libexec/postfix/policyd-spf exit status 1
postfix/smtpd[26506]: warning: premature end-of-input on private/policyd-spf while reading input attribute name

Version-Release number of selected component (if applicable):
pypolicyd-spf-1.3.1-2.fc22.noarch
python-ipaddr-2.1.10-2.fc21.noarch
python-ipaddress-1.0.7-3.fc22.noarch
python-pyspf-2.0.11-1.fc22.noarch

How reproducible:
Always.

Comment 1 Bojan Smojver 2015-07-10 09:36:59 UTC

*** This bug has been marked as a duplicate of bug 1230373 ***


Note You need to log in before you can comment on or make changes to this bug.