Bug 1241963 - Peer not recognized after IP address change
Summary: Peer not recognized after IP address change
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: krishnan parthasarathi
QA Contact:
URL:
Whiteboard:
: 1242546 (view as bug list)
Depends On: 1241274 1242546
Blocks: 1241275 1241904
TreeView+ depends on / blocked
 
Reported: 2015-07-10 13:58 UTC by krishnan parthasarathi
Modified: 2015-11-03 23:06 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1241274
Environment:
Last Closed: 2015-07-30 09:49:43 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description krishnan parthasarathi 2015-07-10 13:58:23 UTC
+++ This bug was initially created as a clone of Bug #1241274 +++

In a user environment, a server might be migrated/restarted with a different IP address than it had before.  DNS has been updated to point the old name at the new address, and thus clients can still reconnect to it OK, but other servers fail to recognize it as a cluster member because of the address change.  In this particular case, the problem is related to containerization of the servers, but it can also occur with bare-metal failover solutions.  The key factor is really that the user is unable/unwilling to configure their routing so that a floating service address can be reassigned to a new physical machine in case of failover or migration.

Extra detail: the problem occurs because the *recipient* of a "peer probe" message initially stores the sender's string-valued IP address instead of its name.  If we then probe in the other direction using that peer's name, we update our peer record with that as well, but that's a total hack and doesn't seem totally foolproof either.  A better solution is to store and subsequently compare against reverse-resolved host names for probes we receive, whenever such names are available.  Such an approach would be effectively immune to such address changes (though it doesn't solve the general problem of DNS errors or misconfiguration).

--- Additional comment from Anand Avati on 2015-07-08 17:35:17 EDT ---

REVIEW: http://review.gluster.org/11587 (glusterd: use a real host name (instead of numeric) when we have one) posted (#1) for review on master by Jeff Darcy (jdarcy@redhat.com)

--- Additional comment from Anand Avati on 2015-07-09 08:48:04 EDT ---

REVIEW: http://review.gluster.org/11587 (glusterd: use a real host name (instead of numeric) when we have one) posted (#2) for review on master by Jeff Darcy (jdarcy@redhat.com)

--- Additional comment from Anand Avati on 2015-07-10 08:35:48 EDT ---

COMMIT: http://review.gluster.org/11587 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 09b808f008150acb980cdf0cd4f945b57aeb71a0
Author: Jeff Darcy <jdarcy@redhat.com>
Date:   Wed Jul 8 09:52:15 2015 -0400

    glusterd: use a real host name (instead of numeric) when we have one
    
    Change-Id: Ie9cc201204d3d613e3e585cab066a07283db902c
    BUG: 1241274
    Signed-off-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-on: http://review.gluster.org/11587
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 1 Anand Avati 2015-07-10 14:55:26 UTC
REVIEW: http://review.gluster.org/11624 (glusterd: use a real host name (instead of numeric) when we have one) posted (#1) for review on release-3.7 by Krishnan Parthasarathi (kparthas@redhat.com)

Comment 2 Jeff Darcy 2015-07-13 14:41:59 UTC
*** Bug 1242546 has been marked as a duplicate of this bug. ***

Comment 3 Kaushal 2015-07-30 09:49:43 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.