This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 124203 - modversions.h missing ? (2.6.5-1.358/smp)
modversions.h missing ? (2.6.5-1.358/smp)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-24 13:18 EDT by Brian O Smith
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-24 13:23:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian O Smith 2004-05-24 13:18:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040510

Description of problem:
modversions.h seems to be missing similar to bug 122354 for FC 1

Hence can't build NVidia binary interface for example:

ERROR: The kernel header file
       '/lib/modules/2.6.5-1.358smp/build/include/linux/modversions.h'
does not
       exist.  The most likely reason for this is that the kernel
header files
       in '/lib/modules/2.6.5-1.358smp/build/include' have not been
       configured.


Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358/kernel-smp-2.6.5-1.358/kernel-source-2.6.5-1.358

How reproducible:
Always

Steps to Reproduce:
1. 

Additional info:

I upgraded FC1 (x86_64) -> FC2 (x86_64) so maybe something's missing,
but I think these files should be in the kernel-source rpm
Comment 1 Arjan van de Ven 2004-05-24 13:23:45 EDT
the makefile of this module isn't adjusted to the 2.6 kernel yet.
Comment 2 Brian O Smith 2004-05-24 13:40:29 EDT
Any pointers to how this has changed from 2.4 to 2.6 so I can report
it to NVidia and get it changed?  The kernel lists are very opaque to me.
Comment 3 Brian O Smith 2004-05-24 13:53:13 EDT
OK, forget it.  Sorry to bug you.  NVidia obviously aready know about
it since their IA32 driver states "support for kernel 2.6" and has a
higher version number. 

Note You need to log in before you can comment on or make changes to this bug.