Bug 124207 - cannot set keyboard repeat rate
cannot set keyboard repeat rate
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libgnome (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-24 14:19 EDT by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-11 17:34:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-05-24 14:19:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
After I updated my libgnome, the keyboard doesn't autorepeat any
more.  When I try to set keyboard autorepeat rates in Preferences ->
Keyboard, I got:

  An error occurred while loading or saving configuration information
  for gnome-settings-daemon.  Some of your configuration settings may
  not work properly.

When I clicked Details, I got:

  Type mismatch: Expected `int' got `float' for key
/desktop/gnome/peripherals/keyboard/rate

Also, when I enabled Repeat Keys, every time I typed a character it is
shown twice.

I am also having problems with icons not showing up on Nautilus.  I
don't know if this is related.

Version-Release number of selected component (if applicable):
libgnome-2.6.0-3

How reproducible:
Always

Steps to Reproduce:
1. Just upgrade libgnome.

    

Additional info:
Comment 1 Rob Greenbank 2004-06-23 09:02:47 EDT
I am also getting similar symptoms -- I have no key repeat, but when I
enable it I get two keys per keystroke.  I was getting the same error
message after I did an upgrade, but have not received that error since
I did a clean install.  I'm using Fedora Core 2.  

I don't recall seeing this problem when I first installed Core 2.  I
did install some of the KDE libraries, and that's when I first saw the
issue (along with my background being messed up).  I uninstalled those
KDE libraries, but all my problems still persist.  
Comment 2 Need Real Name 2004-07-10 20:03:57 EDT
I have more problems: I cannot set the background, and when I tried
setting the theme in Preferences it tells me that it cannot find any
default themes.  Downgrading back to libgnome-2.6.0-2 solves all the
problems.

Is anyone going to look at this?  It's been open for a month and a half.
Comment 3 Paul Eden 2004-09-17 10:51:11 EDT
I have the same problem.  Very annoying.  I would be very happy to
give more details if needed for a fix.

Fedora Core 2
kernel-2.6.8-1.521
libgnome-2.6.0-3
Comment 4 Matthew Miller 2005-04-26 11:32:58 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 5 Ray Strode [halfline] 2005-05-11 17:34:41 EDT
Hi,

This bug is being closed because it has been in the NEEDINFO state for a long
time now.  Feel free to reopen the bug report if the problem still happens for
you and you can provide any information that was requested.

Note You need to log in before you can comment on or make changes to this bug.