Bug 1242274 - Migration does not work when EC is used as a tiered volume.
Summary: Migration does not work when EC is used as a tiered volume.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Lambright
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1236212
Blocks: 1260923 1330765
TreeView+ depends on / blocked
 
Reported: 2015-07-12 20:03 UTC by Dan Lambright
Modified: 2016-04-26 22:19 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1236212
: 1330765 (view as bug list)
Environment:
Last Closed: 2015-07-30 09:47:52 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Dan Lambright 2015-07-12 20:03:14 UTC
+++ This bug was initially created as a clone of Bug #1236212 +++

Migration does not work when EC is used as a tiered volume. This is because a DHT sets a virtual xatter without the trusted.* prefix, and posix tries to apply it to the file, and fails. Consequently none of the other xattrs in the list are set, including EC's configuration information which is mandatory.

--- Additional comment from Anand Avati on 2015-06-26 16:46:09 EDT ---

REVIEW: http://review.gluster.org/11433 (cluster/tier: fixes for migration over ec as cold tier) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-06-26 16:57:37 EDT ---

REVIEW: http://review.gluster.org/11433 (cluster/tier: fixes for migration over ec as cold tier) posted (#2) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-06-27 21:50:19 EDT ---

REVIEW: http://review.gluster.org/11433 (cluster/tier: fixes for migration over ec as cold tier) posted (#3) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-06-27 21:53:21 EDT ---

REVIEW: http://review.gluster.org/11433 (cluster/tier: fixes for migration over ec as cold tier) posted (#4) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-06-28 18:35:38 EDT ---

REVIEW: http://review.gluster.org/11433 (cluster/tier: fixes for migration over ec as cold tier) posted (#5) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-06-29 15:12:59 EDT ---

REVIEW: http://review.gluster.org/11433 (cluster/tier: fixes for migration over ec as cold tier) posted (#6) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-06-30 11:36:31 EDT ---

REVIEW: http://review.gluster.org/11433 (cluster/tier: fixes for migration over ec as cold tier) posted (#7) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-06-30 14:34:22 EDT ---

REVIEW: http://review.gluster.org/11433 (cluster/tier: fixes for migration over ec as cold tier) posted (#8) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-07-02 10:01:01 EDT ---

REVIEW: http://review.gluster.org/11433 (cluster/tier: fixes for migration over ec as cold tier) posted (#9) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-07-09 09:30:17 EDT ---

REVIEW: http://review.gluster.org/11433 (cluster/tier: fixes for migration over ec as cold tier) posted (#10) for review on master by Dan Lambright (dlambrig@redhat.com)

Comment 1 Anand Avati 2015-07-13 23:14:21 UTC
REVIEW: http://review.gluster.org/11652 (cluster/tier: fixes for migration over ec as cold tier) posted (#1) for review on release-3.7 by Dan Lambright (dlambrig@redhat.com)

Comment 2 Kaushal 2015-07-30 09:47:52 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 3 Vijay Bellur 2016-04-26 21:26:48 UTC
REVIEW: http://review.gluster.org/14084 (cluster/tier: fixes for migration over ec as cold tier) posted (#1) for review on release-3.7 by Raghavendra Talur (rtalur@redhat.com)


Note You need to log in before you can comment on or make changes to this bug.