Bug 1242317 - [RFE] Improve I/O latency during signing
Summary: [RFE] Improve I/O latency during signing
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: bitrot
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Venky Shankar
QA Contact: RajeshReddy
bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1242718
TreeView+ depends on / blocked
 
Reported: 2015-07-13 03:16 UTC by Venky Shankar
Modified: 2016-07-13 22:35 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1242718 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:22:53 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Venky Shankar 2015-07-13 03:16:41 UTC
This is an umbrella bug to track the ongoing effort of improving client I/O latencies observed when objects are signed.

Comment 1 Anand Avati 2015-07-13 03:19:56 UTC
REVIEW: http://review.gluster.org/11461 (features/bitrot: move inode state just at the last moment) posted (#2) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 2 Anand Avati 2015-07-13 03:20:03 UTC
REVIEW: http://review.gluster.org/11461 (features/bitrot: move inode state just at the last moment) posted (#3) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 3 Venky Shankar 2015-07-13 03:28:19 UTC
Not moving bug state as there would be multiple patches (first improvement posted) to improve client I/O performance.

Comment 4 Anand Avati 2015-07-13 09:14:21 UTC
COMMIT: http://review.gluster.org/11461 committed in master by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit 14e80e6e5d2d5d4fa568019fbe30cffa52714f87
Author: Venky Shankar <vshankar@redhat.com>
Date:   Tue Jun 30 13:10:46 2015 +0530

    features/bitrot: move inode state just at the last moment
    
    Which was done at half the set expiry time resulting in actual
    IOs incrementing the object version. Now this is done just at
    the last moment with re-notification now cut-shorting into
    checksum calculation without waiting in the timer-wheel.
    
    BUG: 1242317
    Change-Id: If655b77d822ebf7b2a4f65e1b5583dd3609306e7
    Signed-off-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-on: http://review.gluster.org/11461
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 5 Venky Shankar 2015-07-13 09:21:36 UTC
Let's keep this ASSIGNED as there would be other enhancements too (throttle signer, etc.)

Comment 6 Niels de Vos 2016-06-16 13:22:53 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.