Bug 124233 - Gnomemeeting reports gconf key error
Gnomemeeting reports gconf key error
Product: Fedora
Classification: Fedora
Component: gnomemeeting (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Depends On:
  Show dependency treegraph
Reported: 2004-05-24 17:30 EDT by Tim Keitt
Modified: 2008-08-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-14 08:49:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tim Keitt 2004-05-24 17:30:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
Starting gnomemeeting gives:

It appears that you do not have gnomemeeting.server installed in a
valid location. Factory mode disabled.

And a dialog with:

Gconf key error

GnomeMeeting got an invalid value for the GConf key

It probably means that your GConf schemas have not been correctly
installed or the that permissions are not correct.

Please check the FAQ (http://www.gnomemeeting.org/faq.php), the
throubleshoot section of the GConf site
(http://www.gnome.org/projects/gconf/) or the mailing list archives
for more information (http://mail.gnome.org) about this problem.

After that it quits.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install FC2
2. up2date gnomemeeting
3. run gnomemeeting

Actual Results:  Gconf errors

Expected Results:  No gconf errors

Additional info:
Comment 1 Jeff Iddings 2004-06-13 12:05:14 EDT

FAQ was moved. I had the same problem. Their solution worked. 
Comment 2 Daniel Reed 2004-08-27 15:50:26 EDT
Thanks for your report.

I have several rawhide systems and can not reproduce this. I also did
not experience this on FC2.

Please reopen if you have any additional information on how to
reproduce this.
Comment 3 Colin Charles 2004-10-26 13:48:43 EDT
Stock FC2 install, with all updates applied, I get the same errors, so

gconftool-2 --get "/apps/gnomemeeting/general/gconf_test_age" reports: 
No value set for `/apps/gnomemeeting/general/gconf_test_age'

Running gnomemeeting-1.0.2-2.i386. That gconf key should return a
value, which seems in error
Comment 4 Matthew Miller 2005-04-26 12:14:27 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 5 Eric Lambart 2005-06-24 22:46:40 EDT
Hello.  I have encountered this same problem, but with FC3.  I have also fixed
it--and suspect I know why Daniel Reed might not have been able to reproduce it.

Daniel, were these rawhide systems upgrades, or clean installs?

I upgraded directly from RH9->FC3 and tried to install Gnomemeeting today and
encounterd the exact same error.  Going into gconf-editor, I found
/apps/gnomemeeting but there was no "general" category, only, I believe, audio
and video.

gconf-editor and gconftool-2 wouldn't allow me to delete the gnomemeeting key,
so I had to figure out how to do it myself.  It turns out it was lingering
around from RH9, and I guess the gnomemeeting RPM can't overwrite/update those
entries (maybe the install script is crashing when it fails to create
"/apps/gnomemeeting"?).  I recall having seen it before, though I don't think I
ever installed gnomemeeting on this laptop with RH9.

Here is how I fixed the problem.  I'm not sure if all steps were necessary.

As your regular user (not root, unless you're crazy and run gnomemeeting as root):
$ rm -rf ~/.gconf/apps/gnomemeeting (don't do this if you don't have the problem!)

Now, as root:
# gconftool-2 --shutdown
# gconftool-2 --spawn (maybe there's a better way to restart gconfd, but this works)
# rpm -e gnomemeeting
# apt-get install gnomemeeting (or however you would normally install it)

Now try running GnomeMeeting again, it should work.  If you're like me, you
won't be able to find it in the Gnome apps menu, and you'll probably have to
edit its .desktop file to make it show up.

--- is there anything I should do to update this bug?  It's still an FC2 bug so
I hesitate to change the Version to FC3.
Comment 6 Ralf Ertzinger 2006-01-09 03:10:32 EST
Just for info, I encontered this last Friday with a fresh RH install.
Comment 7 Alexander Larsson 2006-08-14 08:49:04 EDT
Ekiga has replaced gnomemeeting. If anyone ever sees this with ekiga, then reopen.

Note You need to log in before you can comment on or make changes to this bug.