Bug 124252 - Can't add keyboard layouts from Keyboard preferences
Can't add keyboard layouts from Keyboard preferences
Status: CLOSED DUPLICATE of bug 120858
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-24 23:17 EDT by Rickford Grant
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rickford Grant 2004-05-24 23:17:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Trying to add keyboard layouts from the Keyboard layout indicator
(replacementfor FC1's Keyboard Layout Switcher) fails and produces
only an error message. No keyboards can be selected.


Version-Release number of selected component (if applicable):
Not sure what compontent to check (FC2 CD install)

How reproducible:
Always

Steps to Reproduce:
1.Add to Panel > Utility > Keyboard Indicator  -- Success
2. right-click and select Open Keyboard Preferences
3.In the Keyboard Preferences Window, click Layouts tab.
4. In that tab select desired layout in Available layouts pane, and
then click the Add button 
    

Actual Results:  error message appears: "Error activating XKB
configuration. Probably internal X server problem.

If you report this situation as a bug, please inlcude

- The result of xprop -root | grep XKB
-The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb

X Server version data: The X.Org Foundation 60700000"


After that the selected layout appears in the left pane, but not in
the panel indicator.

Save error message also appears after clicking the Remove button. If I
scroll through the list of available Keyboard models, the same problem
occurs when I release the mouse, even if I return to the same keyboard
layout.

Expected Results:  Desired layout appears in the left pane and then in
the panel indicator.

Additional info:
Comment 1 Miloslav Trmac 2004-05-27 07:21:52 EDT

*** This bug has been marked as a duplicate of 120858 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.