Bug 124263 - generate_modprobe.conf generates modprobe.conf which hangs machine
Summary: generate_modprobe.conf generates modprobe.conf which hangs machine
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: module-init-tools (Show other bugs)
(Show other bugs)
Version: 2
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-25 10:17 UTC by Peter Hunter
Modified: 2014-03-17 02:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 18:29:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Hunter 2004-05-25 10:17:50 UTC
The following line in modules.conf:

add probeall ip_conntrack ip_conntrack_irc ip_conntrack_ftp

designed to get irc and ftp connection tracking to load when ip_conntrack does gets 
turned into:

install ip_conntrack /sbin/modprobe ip_conntrack_irc; /sbin/modprobe ip_conntrack_ftp; 
/bin/true

which causes a hang as the system tries again and again to insert these two modules.

Deleting that line and using the configuration file for iptables to load the right modules 
works fine, but this was serious since it stopped my machine from booting - every time I 
got to iptables it hung. I had to boot interactively to fix it.

It would have been nice to have had a big dialogue box on the screen of the installer 
saying something like "Warning - new modprobe setup in modprobe.conf. One has been 
automatically generated for you but is not guaranteed to work!"

Version-Release number of selected component (if applicable):
modutils-2.4.26-16

How reproducible:
Always

Steps to Reproduce:
1. Set up a modules.conf containing the line above
2. Use generate_modprobe.conf
3. Load ip_conntrack
    
Actual Results:  Hang

Comment 1 Bill Nottingham 2005-04-19 18:29:59 UTC
Closing bugs on older, no longer supported releases. Apologies for any lack of
response.

This is unlikely to get fixed outside of the upstream generate-modprobe.conf.


Note You need to log in before you can comment on or make changes to this bug.