Bug 1242666 - biosboot and prepboot are not included in anaconda-ks.cfg after installation with custom kickstart file
Summary: biosboot and prepboot are not included in anaconda-ks.cfg after installation ...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-blivet   
(Show other bugs)
Version: 7.1
Hardware: ppc64
OS: Linux
medium
urgent
Target Milestone: rc
: 7.3
Assignee: rmarshall
QA Contact: Release Test Team
Aneta Šteflová Petrová
URL:
Whiteboard:
Keywords:
: 1256249 (view as bug list)
Depends On:
Blocks: 1230910 1256306
TreeView+ depends on / blocked
 
Reported: 2015-07-13 22:26 UTC by jcastran
Modified: 2017-02-09 08:56 UTC (History)
8 users (show)

Fixed In Version: python-blivet-0.61.15.54-1
Doc Type: Bug Fix
Doc Text:
`biosboot` and `prepboot` are now included in the Kickstart file after installation When a Kickstart file included instructions to create `biosboot` or `prepboot` partitions, the Blivet module did not pass this information in Kickstart data. Consequently, after a Kickstart installation, the Kickstart file on the newly installed system did not include the options for creating `biosboot` and `prepboot` partitions and could not be reused successfully on other systems. With this update, the Kickstart output includes these options as expected, and the Kickstart file can be used on other systems to create the `biosboot` and `prepboot` partitions.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 23:49:57 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2168 normal SHIPPED_LIVE python-blivet bug fix and enhancement update 2016-11-03 13:15:34 UTC
IBM Linux Technology Center 128141 None None None Never

Description jcastran 2015-07-13 22:26:38 UTC
Description of problem:
After kickstart installation, /root/anaconda-ks.cfg does not contain either biosboot or prepboot option that is required and was used for kickstart install

Version-Release number of selected component (if applicable):
Rhel 7

How reproducible:
Everytime

Steps to Reproduce:
1. Modify kickstart file to use
      "part biosboot --fstype=biosboot --size=2 --ondisk=sda"
   OR "part prepboot --fstype=prepboot --size=10 --ondisk=sda"
2. Successfully install system using kickstart file
3. Inspect /root/anaconda-ks.cfg on newly installed system for biosboot or prepboot options

Actual results:
anaconda-ks.cfg leaves out prepbot or biosboot options

Expected results:
Options used in kickstart installation should be present in anaconda-ks.cfg file created after installation

Additional info:

Comment 2 Romell Ramjattan 2015-07-15 18:10:45 UTC
This was done on an IBM Power 8 Model 824 server.
We built an LPAR on this and observed the "part prepboot" entry for power systems was excluded each time we installed the system - Either from VNC menus or a NFS kickstart file. THis was build from a Redhat 7.1 BE iso downloaded very recently from RedHat.  If you need further information:  rramjattan@rccl.com or 9546096386

Comment 3 Brian Lane 2015-07-15 23:31:19 UTC
Note for the future, the reason why these aren't being included is that everything w/o a real mountpoint (except swap) is filtered out in blivet in _updateCustomStorageKSData

Comment 5 ibm_cskoehle 2015-07-25 00:18:00 UTC
Hi Brian,
Is this going to still be pursued as a bug?  As of now there is no option for a  kickstart file to work properly for ppc without manually making changes to the anaconda-ks.cfg file.  
Thanks,
Christian
IBM Linux Support

Comment 6 Brian Lane 2015-07-25 01:30:28 UTC
(In reply to ibm_cskoehle from comment #5)
> Hi Brian,
> Is this going to still be pursued as a bug?  As of now there is no option
> for a  kickstart file to work properly for ppc without manually making
> changes to the anaconda-ks.cfg file.  
> Thanks,
> Christian
> IBM Linux Support

Yes, but not for 7.2

Comment 7 ibm_cskoehle 2015-07-31 16:46:15 UTC
All,
Is there anyway the fix for this issue can be included in RHEL 7.2?  It seems like a very small fix and don't really see why the customer should need to wait for a year or more to see this implemented.
Thanks,
Christian

Comment 8 ibm_cskoehle 2015-08-25 19:37:27 UTC
Just checking again on this bug.  Any progress on getting this to be included in RHEL 7.2?

Comment 9 Joey Brown 2015-09-14 14:01:33 UTC
Customer is requesting that this be added to 7.2. I advised the customer that 7.2 is already at a point in development that this may not be possible.

Comment 13 IBM Bug Proxy 2016-02-10 19:00:40 UTC
------- Comment From vsandhya@in.ibm.com 2016-02-10 13:56 EDT-------
Hello Redhat,

Whats the status on this issue?

Comment 15 rmarshall 2016-04-20 18:28:06 UTC
*** Bug 1256249 has been marked as a duplicate of this bug. ***

Comment 25 errata-xmlrpc 2016-11-03 23:49:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2168.html


Note You need to log in before you can comment on or make changes to this bug.