Bug 1242743 - mutt warns about missing gpg-agent
Summary: mutt warns about missing gpg-agent
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutt
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matej Mužila
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-14 06:13 UTC by Petr Pisar
Modified: 2015-10-03 21:18 UTC (History)
3 users (show)

Fixed In Version: mutt-1.5.24-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-03 21:18:15 UTC


Attachments (Terms of Use)

Description Petr Pisar 2015-07-14 06:13:38 UTC
When starting mutt with crypt_use_gpgme configuration option set to "yes", the mutt complains about missing gpg-agent and waits for a key press:

$ LC_ALL=en_US.UTF-8 mutt

Using GPGME backend, although no gpg-agent is running
Press any key to continue...

Recent gnupg2's gpg-agent does not export any environment variables, so the mutt's check is pointless and annoying. I have installed:

$ rpm -q mutt gnupg2 gpgme
mutt-1.5.23-9.fc22.x86_64
gnupg2-2.1.5-1.fc22.x86_64
gpgme-1.4.3-5.fc22.x86_64

I guess you should apply this upstream patch <http://article.gmane.org/gmane.mail.mutt.devel/21882/match=gpg_agent_info>.

Comment 1 Petr Pisar 2015-08-25 07:58:23 UTC
Which mutt build delivers the fix? I cannot see anything newer than the affected mutt-1.5.23-9.fc22.x86_64.

Comment 2 Petr Pisar 2015-08-31 06:22:17 UTC
I'm sorry, but it's not fixed in Fedora 22.

Comment 3 Matej Mužila 2015-08-31 13:45:16 UTC
Hi,

it should be fixed in f23 (mutt-5:1.5.23-10.20150609hg17a4f92e4a95.fc23).

There is used newer snapshot of mutt (because in version 1.5.23 it uses deprecated gnutls functions not available in fedora >= 23). The snapshot used in fedora >= 23 should contain the upstream patch.

Yes, the CURRENTRELEASE resolution was not chosen properly.

Comment 4 Fedora Update System 2015-09-29 21:34:30 UTC
mutt-1.5.24-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15073

Comment 5 Fedora Update System 2015-10-03 21:18:11 UTC
mutt-1.5.24-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.