Bug 124275 - PS/2 mouse works neither in console nor in X
PS/2 mouse works neither in console nor in X
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-25 08:42 EDT by Janos Lichtenberger
Modified: 2015-01-04 17:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:32:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot log (29.02 KB, text/plain)
2004-05-26 06:23 EDT, Janos Lichtenberger
no flags Details

  None (edit)
Description Janos Lichtenberger 2004-05-25 08:42:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
On an Asus P4T533-C motherboard,  PS/2 mices never work: neither under
install (I used text mode install) nor in virtual console nor in X.
USB mice work fine.
The very same PS/2 mouse works fine on another PC with different
motherboard and the content of /etc/sysconfig/hwconw and
/etc/sysconfig/mouse files are the same on both PC!

Version-Release number of selected component (if applicable):
kudzu-1.1.62-1

How reproducible:
Always

Steps to Reproduce:
1.Boot 
2. Start X
    

Actual Results:  1. No mouse in virtual console
2. No mouse in X

Expected Results:  Working mouse

Additional info:
Comment 1 Janos Lichtenberger 2004-05-25 09:32:05 EDT
The same hardware works fine with RH9
Comment 2 Bill Nottingham 2004-05-25 16:04:19 EDT
Do you get any kernel messages on boot about the PS/2 port?

What's the contents of /proc/bus/input/devices?
Comment 3 Eelco Hoekema 2004-05-26 04:31:37 EDT
I too have a mouse problem (might be related). 
It won't work after a cold boot. 
Hitting the reset switch after RHGB starts usually helps.

I use a PS/2 mouse. I've tried a Logitech Pilot Wheel mouse and a
Genius Optical mouse - have the same problem with both.

Asus A7V600 mainboard.
Comment 4 Janos Lichtenberger 2004-05-26 06:23:18 EDT
Created attachment 100571 [details]
boot log
Comment 5 Bill Nottingham 2004-05-26 15:39:50 EDT
Hm, that's a normal-looking boot log.
Comment 6 John Steinman 2004-06-13 06:55:11 EDT
After doing a fresh install from FC1 of FC2 my PS Mouse on the serial
port of my laptop nolonger works. I tried using "kudzu" but still no
luck. When I reboot the console messages indicates that no mouse is
configured. It does not look like the check for new hardware is
detecting that I now have a mouse connected to the serial port.

When I did the fresh install the mouse was not connected to the
laptop. I am not sure if it will make any difference but I am going to
attempt to do another fresh install this time with the mouse installed.
Comment 7 John Steinman 2004-06-13 08:22:37 EDT
I tried a fresh FC2 Install with the PS Mouse plugged into the mouse
serial port on my laptop. The start messages indicated that a Generic
PS2 mouse was detected but the mouse connected the mouse serial port
does not respond. The Synaptics Touchpad however still functions with
or without the PS2 serial mouse plugged in.
Comment 8 Alan Cox 2004-06-18 21:24:23 EDT
Please try the errata kernel, that fixes some of these problems. In
some other cases disabling USB legacy in the bios helps, which we are
still working on
Comment 9 Janos Lichtenberger 2004-08-10 10:05:09 EDT
Sorry for the late reply.
If I disable USB Legacy support, the PC hangs up just after the IDE
BUS scan.
I tried kernel 2.6.6-1.435. No change
Comment 10 Dave Jones 2005-04-16 01:32:52 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.