Bug 1242822 - [RFE] filter for "Allocation Policy" in Disks search
Summary: [RFE] filter for "Allocation Policy" in Disks search
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: ---
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-4.2.4
: ---
Assignee: Tal Nisan
QA Contact: Shir Fishbain
URL:
Whiteboard:
Depends On:
Blocks: 1098612
TreeView+ depends on / blocked
 
Reported: 2015-07-14 08:54 UTC by Jiri Belka
Modified: 2019-04-28 09:53 UTC (History)
9 users (show)

Fixed In Version: ovirt-engine-4.2.4.1
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:38:37 UTC
oVirt Team: Storage
ylavi: ovirt-4.2+
ylavi: planning_ack+
rule-engine: devel_ack+
ratamir: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 91727 0 master MERGED webadmin: Allow filtering allocation policy in disks tab 2018-05-29 14:28:15 UTC
oVirt gerrit 91733 0 ovirt-engine-4.2 MERGED webadmin: Allow filtering allocation policy in disks tab 2018-05-29 16:38:49 UTC

Description Jiri Belka 2015-07-14 08:54:50 UTC
Description of problem:

In 'Disks' (click Images) there's 'Allocation policy' column. But I can't use allocation policy type in search.

Please review search and visible columns in Admin portal that they match, that is one can use same options in search as visible in Admin portal and visa-versa.

Especially useful as column sorting is not complete in Admin Portal.

Version-Release number of selected component (if applicable):
3.6

How reproducible:


Steps to Reproduce:
1. use search: Disks: $allocation_policy_option_name = Preallocated
2.
3.

Actual results:
not possible to search with this option

Expected results:
should work, all visible columns in maintab should be usable in search as options

Additional info:

Comment 1 Oved Ourfali 2015-07-15 08:43:31 UTC
The specific use-case you've mentioned is storage one, so setting it as such for consideration.
Doing it widely requires a lot of work from different verticals, and I'm not sure all options are needed.

Comment 2 Yaniv Lavi 2016-12-06 11:12:54 UTC
Changing summary to capture the mentioned use case.

Comment 3 Red Hat Bugzilla Rules Engine 2018-05-27 13:03:00 UTC
This request has been proposed for two releases. This is invalid flag usage. The ovirt-future release flag has been cleared. If you wish to change the release flag, you must clear one release flag and then set the other release flag to ?.

Comment 4 Sandro Bonazzola 2018-06-01 08:05:17 UTC
4.2.4 bug is bug #1098612

Comment 5 Yaniv Lavi 2018-06-11 06:39:45 UTC
(In reply to Sandro Bonazzola from comment #4)
> 4.2.4 bug is bug #1098612

We always target the earliest release that includes a fix.

Comment 6 Sandro Bonazzola 2018-06-15 09:57:22 UTC
(In reply to Yaniv Lavi from comment #5)
> (In reply to Sandro Bonazzola from comment #4)
> > 4.2.4 bug is bug #1098612
> 
> We always target the earliest release that includes a fix.

So you'll miss regression testing in the next release.
This bug has been already cloned for 4.2.4 testing in bug #1098612.
But I don't want to interfere.

Comment 7 Shir Fishbain 2018-06-19 12:13:49 UTC
The Allocation Policy filter is allowed
For verification used 4.2.4.4-0.1.el7_3

Comment 8 Sandro Bonazzola 2018-06-26 08:38:37 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.