Bug 1242879 - hammer content-view --help having wrong description at remove-version subcommand
Summary: hammer content-view --help having wrong description at remove-version subcommand
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Pavel Moravec
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-14 10:17 UTC by Pavel Moravec
Modified: 2019-04-01 20:26 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-07-27 11:27:32 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 11110 None None None 2016-04-22 16:09 UTC

Description Pavel Moravec 2015-07-14 10:17:26 UTC
Description of problem:
content-view --help prints:

    remove-version                Update a content view
    update                        Update a content view


Version-Release number of selected component (if applicable):
rubygem-hammer_cli_katello-0.0.4-14.el6sat.noarch (but seen in upstream as well)


How reproducible:
100%


Steps to Reproduce:
hammer -u admin -p password content-view --help


Actual results:
remove-version has description "Update a content view" / copied from the next subcommand description.


Expected results:
remove-version to have some relevant description.


Additional info:
Upstream PR on the way

Comment 3 Bryan Kearney 2015-08-14 17:02:00 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11110 has been closed
-------------
Pavel Moravec
Upstream PR: https://github.com/Katello/hammer-cli-katello/pull/303
-------------
Pavel Moravec
Applied in changeset commit:hammer-cli-katello|5605803013a517e572845c6ac33ae09743af8064.

Comment 4 Tazim Kolhar 2015-10-29 11:17:36 UTC
*** This bug is verified in upstream.  This fix should eventually land in future downstream builds ***
Version Tested
# rpm -qa | grep foreman
foreman-proxy-1.11.0-0.develop.201510201341git00875b3.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
foreman-debug-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-compute-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-release-scl-1-1.el7.x86_64
foreman-gce-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_11.el7.noarch
foreman-vmware-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-1.noarch
foreman-ovirt-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
foreman-release-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-libvirt-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-postgresql-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201510201150gitab068d9.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch

steps:
# hammer content-view --help
 remove-version                Remove a version of a content view
 update                        Update a content view

Comment 8 Bryan Kearney 2016-07-27 11:27:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.