Bug 124292 - kde assumed as default in switchdesk-gui.py
kde assumed as default in switchdesk-gui.py
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: switchdesk (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-25 09:57 EDT by Øyvind Stegard
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-26 19:25:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Øyvind Stegard 2004-05-25 09:57:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Hi,
This is a few lines from the python script (w/line numbers):
/usr/share/switchdesk/switchdesk-gui.py
---
53 class mainDialog:
54    def __init__(self):
55        self.wm = ' kde'
                                                                     
          ---

KDE is the assumed default. I don't have KDE installed at all. So,
when  I start switchdesk, I get to choose between Gnome and TWM (in
that order), which is fine. BUT if I choose Gnome, but don't actually
click its radio button (because it is already pre-selected, being the
first choice), the self.wm variable is still ' kde', which then
produces an error message telling me KDE ins't installed. But I didn't
choose KDE, I chose Gnome. The problem can easily be worked around by
clicking on the Gnome radio button explicitly, even though it is
already selected. This causes the right event to be triggered in the
python script(on_gnomeRB_clicked), and the self.wm variable to be
updated correctly to " gnome". 

The bug is trivial and probably very easy to fix, but I've no
experience with Python at all, otherwise I'd throw together a patch.
But the developers in charge will probably fix it in 5 seconds anyway.

Cheers,
Oeyvind Stegard

Version-Release number of selected component (if applicable):
4.0.3-1

How reproducible:
Always

Steps to Reproduce:
1. Start switchdesk, make sure KDE is not installed
2. Don't click any radio buttons, just the dialog OK button (that is,
say OK to whatever's on top of the list)
3. Watch as switchdesk tells you KDE is not installed, and that the
configuration could not be updated.
    

Actual Results:  No updated configuration.

Expected Results:  Updated configuration.

Additional info:

Trivial, but annoying.
Comment 1 Ngo Than 2004-05-26 19:25:45 EDT
it's fixed in 4.0.4-1, which will be showed up in rawhide soon. Thanks
for your report

Note You need to log in before you can comment on or make changes to this bug.