Bug 1242983
| Summary: | heat fail to delete overcloud stack since it wait for host provision_state | ||||||
|---|---|---|---|---|---|---|---|
| Product: | Red Hat OpenStack | Reporter: | Ofer Blaut <oblaut> | ||||
| Component: | openstack-tripleo-heat-templates | Assignee: | Jay Dobies <jason.dobies> | ||||
| Status: | CLOSED DUPLICATE | QA Contact: | yeylon <yeylon> | ||||
| Severity: | high | Docs Contact: | |||||
| Priority: | unspecified | ||||||
| Version: | Director | CC: | mburns, rhel-osp-director-maint, srevivo | ||||
| Target Milestone: | z1 | ||||||
| Target Release: | Director | ||||||
| Hardware: | Unspecified | ||||||
| OS: | Unspecified | ||||||
| Whiteboard: | |||||||
| Fixed In Version: | Doc Type: | Bug Fix | |||||
| Doc Text: | Story Points: | --- | |||||
| Clone Of: | Environment: | ||||||
| Last Closed: | 2015-07-16 17:20:40 UTC | Type: | Bug | ||||
| Regression: | --- | Mount Type: | --- | ||||
| Documentation: | --- | CRM: | |||||
| Verified Versions: | Category: | --- | |||||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||
| Embargoed: | |||||||
| Attachments: |
|
||||||
*** This bug has been marked as a duplicate of bug 1242796 *** |
Created attachment 1051869 [details] nova list output Description of problem: heat stack-delete overcloud will fail because of waiting for hosts to change their provision state [stack@puma33 ~]$ heat stack-delete overcloud [stack@puma33 ~]$ heat stack-list +--------------------------------------+------------+---------------+----------------------+ | id | stack_name | stack_status | creation_time | +--------------------------------------+------------+---------------+----------------------+ | 995abf87-36f8-45b7-bf1c-3c08d0621ee5 | overcloud | DELETE_FAILED | 2015-07-14T12:14:18Z | +--------------------------------------+------------+---------------+----------------------+ attached nova output Version-Release number of selected component (if applicable): How reproducible: Steps to Reproduce: 1.create overcloud stack on BM 2.delete overcloud stack on BM , check it fails 3. Actual results: Expected results: Additional info: workaround, delete nova servers and delete stack again