Bug 124302 - nonint_oldconfig is interactive on choices with NEW items
nonint_oldconfig is interactive on choices with NEW items
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-25 11:04 EDT by Daniel Hokka Zakrisson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-29 04:48:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated nonint_oldconfig patch (3.37 KB, patch)
2004-05-25 11:06 EDT, Daniel Hokka Zakrisson
no flags Details | Diff

  None (edit)
Description Daniel Hokka Zakrisson 2004-05-25 11:04:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
When a choice has a NEW item, nonint_oldconfig acts interactive,
asking the user for what option should be used. This causes builds to
stall, for no apparent reason.

Version-Release number of selected component (if applicable):
kernel-2.6.6-1.383

How reproducible:
Always

Steps to Reproduce:
1. perl -p -i -e 's/.*CONFIG_X86_ELAN.*//' .config
2. make nonint_oldconfig
Comment 1 Daniel Hokka Zakrisson 2004-05-25 11:06:45 EDT
Created attachment 100541 [details]
Updated nonint_oldconfig patch

This patch updates the fourth hunk to conf.c, making it use the default value
even if there are new items.
Comment 2 Arjan van de Ven 2004-05-29 04:48:42 EDT
added for the next build; thanks.
Comment 3 Timur Tabi 2004-12-16 10:54:55 EST
Was this supposed to be fixed in FC3?  Because it hasn't been.  I
issued these commands:

make mrproper
cp /boot/config-2.6.9-1.667smp .config
make oldconfig

And then it prompted me for this option:

Use 4Kb for kernel stacks instead of 8Kb (4KSTACKS) [N/y/?] (NEW)
Comment 4 Daniel Hokka Zakrisson 2004-12-16 11:19:36 EST
Re comment #3:
This bug is for the nonint_oldconfig target, which isn't supposed to
be interactive, while the oldconfig target is supposed to be
interactive and the behaviour you described is hence valid.
The bug is indeed fixed in FC3.

Note You need to log in before you can comment on or make changes to this bug.