Bug 124304 - cyrus-sasl-2.1.18-3 does not compile
cyrus-sasl-2.1.18-3 does not compile
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: cyrus-sasl (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On: 124303
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-25 11:19 EDT by Steve Grubb
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-27 17:38:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2004-05-25 11:19:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
The current cyrus sasl package cannot locate the des.h header when
building the 2.1 section. Please apply the following patch to the spec
file:

--- working/cyrus-sasl/cyrus-sasl.spec  2004-05-13 08:59:34.000000000
-0400
+++ /opt/specs/cyrus-sasl.spec  2004-05-25 11:11:41.000000000 -0400
@@ -43,7 +43,7 @@
 %if %{includev1}
 BuildPrereq: gdbm-devel
 %endif
-BuildPrereq: autoconf, automake, libtool
+BuildPrereq: autoconf, automake >= 1.8, libtool
 BuildPrereq: krb5-devel >= 1.2, openssl-devel, pam-devel, pkgconfig
 Prereq: /sbin/ldconfig, chkconfig, /sbin/service
                                                                     
          
@@ -218,7 +218,7 @@
 # confused.  Aaargh.
 ac_cv_can_build_shared=yes
 export ac_cv_can_build_shared
-%configure \
+%configure CFLAGS=-I/usr/include/openssl \
        --disable-shared --disable-static --enable-${buildtype} \
        --disable-java \
        --with-plugindir=%{_plugindir2} \


Version-Release number of selected component (if applicable):
cyrus-sasl-2.1.18-3

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -bb /usr/src/redhat/cyrus-sasl.spec
    

Actual Results:  Compile stops saying it can't find the des.h file and
a whole bunch of other problems spew out because of the unlocated file.

Expected Results:  A message indicating where the rpm was written to.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.