Bug 1243060 - wildcards match uninstalled packages on upgrade
Summary: wildcards match uninstalled packages on upgrade
Keywords:
Status: CLOSED DUPLICATE of bug 1234763
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-14 16:45 UTC by Stuart D Gathman
Modified: 2015-07-15 09:28 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-15 09:28:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Stuart D Gathman 2015-07-14 16:45:28 UTC
Description of problem:
dnf update o\* matches all packages beginning with o, not just installed packages.

Version-Release number of selected component (if applicable):
dnf-1.0.1-2.fc22.noarch

How reproducible:
always

Steps to Reproduce:
1. dnf check-update to list packages with updates
2. dnf update perl\*  or similar wildcard to update some of the packages with updates
3. 

Actual results:
A very, very, very, very, long list of packages that it won't update:
... [ many pages ] ...
Package perl-Crypt-DH-GMP not installed, cannot update it.
Package perl-Razor-Agent not installed, cannot update it.
Package perl-Proc-Wait3 not installed, cannot update it.
Package perl-Devel-CheckCompiler not installed, cannot update it.
Package perl-Test-HTTP-Server-Simple-StashWarnings not installed,
... [ many more pages ] ...


Expected results:
Just the packages being updated.

Additional info:
-q does not help.  Redirecting stderr also redirects the ok y/n? query.

Comment 1 Honza Silhan 2015-07-15 09:28:10 UTC

*** This bug has been marked as a duplicate of bug 1234763 ***


Note You need to log in before you can comment on or make changes to this bug.