Bug 124312 - Memory Detection - Install kernal boot failure
Memory Detection - Install kernal boot failure
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-25 12:08 EDT by Steve Stephens
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-17 08:34:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Stephens 2004-05-25 12:08:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040113

Description of problem:
Target system is Compaq Proliant 5000 w/ 512MB

System hangs after displaying on console:

Uncompressing Linux... Ok, booting the kernel.

Version-Release number of selected component (if applicable):
Fedora core 2 

How reproducible:
Always

Steps to Reproduce:
1.Boot from Fedora Core 2 CD 1
2.Reply "linux mem=exactmap mem=640k@0 mem=511m@1m" to boot: 
3.
    

Expected Results:  The installation kernel should boot.

Additional info:
Comment 1 Dave Jones 2004-05-26 07:29:01 EDT
I'm fairly sure I did an install on one of these during FC2 test,
using just mem=512M  does that work for you?
Comment 2 Steve Stephens 2004-05-27 13:53:43 EDT
"linux mem=512m" fails also. linux can't boot from device <null>.
Comment 3 Dave Jones 2004-05-27 14:08:56 EDT
ah, but it gets further than before right ?
This new error sounds like something else, like it isn't finding your
root device for some reason.
Comment 4 Steve Stephens 2004-05-27 15:30:01 EDT
The fact remains that the options that worked for FC1 do not work for
FD2: "linux mem=exactmap mem=640k@0 mem=511m@1m". Does the support org
have access to equipment to replicate? 

When I do not provide any options,the kernel does not detect enough
memory to continue. This is consistant between FC1 & FC2. I conclude
that there is not a hardware or media problem.

If I try again by specifying the the mem option ("linux
mem=512m"),3what is the "root" option? 

Comment 5 Steve Stephens 2004-05-27 15:57:41 EDT
I just tried mem=512m on FC1 with similar results. The Kernel cannot 
boot from the ramdisk.
Comment 6 Dave Jones 2004-05-27 16:22:02 EDT
it seems that this code got changed in 2.5 to reflect changes in 2.4,
and then got backed out and replaced with memmap= for the above
functionality.  2.4 never changed accordingly.
I'm trying to sort this mess out upstream right now on the
linux-kernel mailing list.
Comment 7 Steve Stephens 2004-05-27 16:46:19 EDT
Glad I could be helpfull.
Comment 8 Dave Jones 2004-06-17 08:34:05 EDT
upstream opinion is that things aren't going to change.
so, for 2.6 kernels use memmap=, 2.4 use mem=

exactmap now belongs to the memmap argument.

Note You need to log in before you can comment on or make changes to this bug.