Bug 124337 - Thinkpad T40 doesn't suspend (ACPI/s3) with the test kernel-2.6.6-1.383.i686
Thinkpad T40 doesn't suspend (ACPI/s3) with the test kernel-2.6.6-1.383.i686
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2004-05-25 14:54 EDT by Satish Balay
Modified: 2015-01-04 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-11-29 01:04:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg output (12.93 KB, text/plain)
2004-05-25 14:56 EDT, Satish Balay
no flags Details
lspci -vv output (8.76 KB, text/plain)
2004-05-25 14:57 EDT, Satish Balay
no flags Details
lspci -vv from IBM R50p (8.77 KB, text/plain)
2004-06-17 08:39 EDT, Brian Long
no flags Details

  None (edit)
Description Satish Balay 2004-05-25 14:54:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
The T40 doesn't go into suspend state (s3) in "echo 3 >
/proc/acpi/sleep" command is invoked

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot to kernel-2.6.6-1.383.i686
2. as root invoke:
echo 3 > /proc/acpi/sleep

Actual Results:  The laptom doesn't enter suspend state - it just
comes back to a normal screen/operation

Expected Results:  The laptop should suspend

Additional info:

This works with the release kernel-2.6.5-1.358
Comment 1 Satish Balay 2004-05-25 14:56:35 EDT
Created attachment 100553 [details]
dmesg output
Comment 2 Satish Balay 2004-05-25 14:57:46 EDT
Created attachment 100554 [details]
lspci -vv output
Comment 3 Arjan van de Ven 2004-05-29 04:18:18 EDT
can you try to do
rmmod ehci_hcd
rmmod ohci_hcd
and see if you can then suspend ?
Comment 4 Satish Balay 2004-05-29 15:53:43 EDT
I tried rmmod ehci_hcd - and then it could suspend.

Interestingly after the first suspend - the following worked:
- " modprobe ehci_hcd  ; echo 3 > /proc/acpi/sleep"

I've also tried kernel-2.6.6-1.397 - the same behavior - except for
the last part. I had to remove ehci_hcd for subsequent suspend as well. 
Comment 5 Brian Long 2004-06-17 08:37:59 EDT
Just duplicated this on IBM R50p running FC2 with latest errata kernel
2.6.6-1.435.  Logged into X as myself, xterm as root.  "echo 3 >
/proc/acpi/sleep" failed to suspend.

I tried "rmmod ehci_hcd" and "echo 3 > /proc/acpi/sleep".  It
suspended, but when I hit the power button, it came back to a Fedora
login screen.
Comment 6 Brian Long 2004-06-17 08:39:42 EDT
Created attachment 101218 [details]
lspci -vv from IBM R50p
Comment 7 Dave Jones 2004-11-27 15:21:37 EST
mass update for old bugs:

Is this still a problem with the 2.6.9 based update kernel ?
Comment 8 Satish Balay 2004-11-27 16:41:03 EST
ACPI suspend/resume works fine with 'FC3/kernel-2.6.9-1.681_FC3' (without
'modprobe -r ehci_hcd') on the T40

(however I mostly use APM instead of ACPI)

This issue can be considered resolved

Note You need to log in before you can comment on or make changes to this bug.