Bug 1243382 - EC volume: Replace bricks is not healing version of root directory
Summary: EC volume: Replace bricks is not healing version of root directory
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Ashish Pandey
QA Contact: Bhaskarakiran
URL:
Whiteboard:
Depends On: 1241862
Blocks: 1243384
TreeView+ depends on / blocked
 
Reported: 2015-07-15 10:55 UTC by Ashish Pandey
Modified: 2016-11-23 23:11 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1241862
: 1243384 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:24:08 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-07-15 11:31:12 UTC
REVIEW: http://review.gluster.org/11676 ( ec : trusted.ec.version xattr of all directories/files       on all the bricks should be same after heal. This       includes the root directory of the bricks.) posted (#1) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 2 Anand Avati 2015-07-15 11:39:05 UTC
REVIEW: http://review.gluster.org/11676 (ec : trusted.ec.version xattr of all root directories      of all bricks should be same.) posted (#2) for review on master by Ashish Pandey (aspandey@redhat.com)

Comment 3 Anand Avati 2015-08-28 08:54:41 UTC
REVIEW: http://review.gluster.org/11676 (ec : trusted.ec.version xattr of all root directories of all bricks should be same.) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 4 Anand Avati 2015-08-29 10:32:25 UTC
COMMIT: http://review.gluster.org/11676 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 44e58a9385b0661c7015b317669c01c699ee9a3e
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Wed Jul 15 16:37:37 2015 +0530

    ec : trusted.ec.version xattr of all root directories of all bricks should be same.
    
    Problem:
    After replacing the brick using "replace-brick" command and running "heal
    full", the version of the root directory of the newly added brick is not
    getting healed. heal starts running on the dentries of the root but does not
    run on root directory.
    
    Solution:
    Run heal on root directory.
    
    Change-Id: Ifd42a3fb341b049c895817e892e5b484a5aa6f80
    BUG: 1243382
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: http://review.gluster.org/11676
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

Comment 5 Mike McCune 2016-03-28 22:16:42 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 6 Niels de Vos 2016-06-16 13:24:08 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.