Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1243535 - os-maven-plugin: Fails build on unknown architecture
os-maven-plugin: Fails build on unknown architecture
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: os-maven-plugin (Show other bugs)
22
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-15 13:09 EDT by Rafael Fonseca
Modified: 2015-07-31 04:43 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.2.3-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-31 04:20:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
netty build log on s390x (10.84 KB, text/plain)
2015-07-15 13:09 EDT, Rafael Fonseca
no flags Details

  None (edit)
Description Rafael Fonseca 2015-07-15 13:09:15 EDT
Created attachment 1052397 [details]
netty build log on s390x

Description of problem: Netty build fails on s390x with a message "[ERROR] unknown os.arch: s390x"

Version-Release number of selected component (if applicable): 4.0.28-2


How reproducible: Just build netty on an s390x machine.


Steps to Reproduce:
1.
2.
3.

Actual results: netty fails because os-maven-plugin does not recognize s390x architecture.


Expected results:


Additional info:
Comment 1 Mikolaj Izdebski 2015-07-15 13:14:24 EDT
Thanks. Will be fixed tomorrow morning.
Comment 2 Dan Horák 2015-07-17 11:21:12 EDT
for the record - netty builds with the fixed os-maven-plugin - 
http://s390.koji.fedoraproject.org/koji/buildinfo?buildID=335615
Comment 3 Mikolaj Izdebski 2015-07-21 03:31:20 EDT
Fixed in os-maven-plugin-1.2.3-4
Comment 4 Mikolaj Izdebski 2015-07-21 03:44:30 EDT
Built for f21 and f22, however no f21 update will be submitted.
Comment 5 Fedora Update System 2015-07-21 03:45:42 EDT
os-maven-plugin-1.2.3-4.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/os-maven-plugin-1.2.3-4.fc22
Comment 6 Mikolaj Izdebski 2015-07-23 05:07:17 EDT
Moving to QA for testing.
Comment 7 Fedora Update System 2015-07-31 03:57:09 EDT
os-maven-plugin-1.2.3-4.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Mikolaj Izdebski 2015-07-31 04:20:04 EDT
I believe that this bug is fixed in os-maven-plugin-1.2.3-4,
which is available in updates for Fedora 22, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=670381

Note You need to log in before you can comment on or make changes to this bug.