Bug 124366 - Sun's java JDK's segfault on an athlon 64
Sun's java JDK's segfault on an athlon 64
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2004-05-25 20:36 EDT by Marc Heckmann
Modified: 2015-01-04 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-16 00:38:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Marc Heckmann 2004-05-25 20:36:56 EDT
Description of problem: 
Using either the stable 32bit Java 1.4.2 sdk or the beta 1.5.0 64 bit one from 
http://java.sun.com, I get segfaults when trying to run Jakarta-tomcat-4.1.30 from 
How reproducible: 
Steps to Reproduce: 
1. set JAVA_HOME to where the SDK live. 
2. turn on coredumps with ulimit -c 10000000 
3. cd jakarta-tomcat-4.13 
4. ./bin/startup.sh 
5. access a webapp via your browser. 
6. look at the segfaults (via dmesg) or core file 
The machine passed a round of memtest86 testing. 
I can send in more info upon request.
Comment 1 Marc Heckmann 2004-05-25 20:39:01 EDT
oops, the above should read "cd jakarta-tomcat-4.1.30", not 4.13. 
I haven't tried the blackdown or IBM JDK's yet, but I will.  
I've also tried LD_ASSUME_KERNEL=2.4.19 and 2.2.5 
Comment 2 Marc Heckmann 2004-05-25 23:39:26 EDT
one more detail, the processes segfault with signal 6 SIGABRT.

Comment 3 Marc Heckmann 2004-06-14 13:40:58 EDT
the fix for this (turned out to be a false message) is in the most
recent bk kernels (post 2.6.7-rc3 I believe).
see http://bugzilla.kernel.org/show_bug.cgi?id=2839

It might be a good idea to include it in a future update release as it
avoids user confusion.

Comment 4 Dave Jones 2005-04-16 00:38:35 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.