Bug 124372 - hwclock ok, but system clock runs about 40% fast on 2 thinkpads
hwclock ok, but system clock runs about 40% fast on 2 thinkpads
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-25 21:14 EDT by George Hein
Modified: 2015-01-04 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:32:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Hein 2004-05-25 21:14:34 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
install on Thinkpad-t20 or 240x

Steps to Reproduce:
1.
2.
3.
  
Actual results: especially amusing watching a video using xine


Expected results:


Additional info:
Comment 1 Don Vanco 2004-05-26 15:30:53 EDT
Not me personally, but a fellow LUGer just installed this on what he
has described as a "5 year old laptop" and is experiencing the same
issue.  I have requested that he post in detail.

Don
Comment 2 Ryan W. Frenz 2004-05-26 15:35:36 EDT
I am said LUGer.  The laptop is an IBM iSeries 1412-2611.  Celeron
375MHz and 192 MB RAM, clean install of FC2.  The clock runs about 1
minute every 35 real seconds.  It syncs to 128.118.46.3 (psu ntp
server), but it's only correct momentarily after each sync.

Ryan
Comment 3 Bryan J. Field 2004-05-28 10:27:45 EDT
I also had this problem. My laptop is also an IBM iSeries 1412-2611,
but with a Celeron 366Mhz and 512MB of RAM. I had been running an
upgraded version of FC2. The system had been continuously upgraded
from 7.2 -> 8.0 -> 9 -> fc1 -> fc2. My clock ran twice as fast and
according to gkrellm, it also seemed that the processor ran at half
the correct speed. It would say it was peaking at 182MHz and the
system ran quite slow (as expected). The /proc/cpuinfo/ file had the
correct information. I too would ntp the clock, but then it would just
run away like mad again.

I needed to use the computer so I've done a clean install back to fc1,
but I would really like to go to fc2 if there is a fix to this
problem. I've looked around with google and a few other people have
reported this problem with the 2.6 kernel, but on different
distrobutions (like Debian) but no one has a fix.

Bryan
Comment 4 Ryan W. Frenz 2004-05-28 10:33:03 EDT
Yeah we have the same machine (except for RAM).  I also got rid of 
FC2 until this is sorted out.  Interestingly, I'm now running 
Slackware 9.1 with 2.6.5 from kernel.org, and the clock is perfect.  
The problem must be somewhere in the difference between stock 2.6.5 
and the version FC2 uses by default.  Any other suggestions are 
welcome.

Ryan
Comment 5 Bryan J. Field 2004-06-09 14:07:41 EDT
I looked around some more this week to see if anyone else had the
solution to the fast clock problem and I found this great post:

http://www.uwsg.iu.edu/hypermail/linux/kernel/0403.3/0834.html

Do any of you still have this running to try it out? I would like to
see if it works, but I have moved back to fc1 and am a little weary of
trying this again until I know it works.

On the plus side, its the exact same notebook we have.

Bryan
Comment 6 George Hein 2004-06-09 16:30:38 EDT
Tried clock=pit and after 10 minutes the clock seems OK

Note that the ThinkPad-T20 is a bit old so I turned acpi=off so as a 
result the clock=pmtmr probably will not work (did not try it).
I am using acpi=off to get suspend to work, still doesn't in Fed2.
It did work with RH9 and MDK92, but only with 2.4 kernels, and in
MKD10 only with acpi=off and 2.4.


Comment 7 Dave Jones 2005-04-16 00:32:39 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.