Bug 1243753 - Gluster cli logs invalid argument error on every gluster command execution
Summary: Gluster cli logs invalid argument error on every gluster command execution
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: mainline
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1244103
TreeView+ depends on / blocked
 
Reported: 2015-07-16 08:50 UTC by Anoop C S
Modified: 2016-05-28 06:01 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1244103 (view as bug list)
Environment:
Last Closed: 2016-05-28 06:00:32 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Anoop C S 2015-07-16 08:50:55 UTC
Description of problem:
Each every time when a gluster command is executed directly, the following error is being logged in cli logs.

[2015-07-16 06:21:22.746577] E [mem-pool.c:417:mem_get0] (-->/usr/local/lib/libglusterfs.so.0(+0x7e262) [0x7fdbc0b1f262] -->/usr/local/lib/libglusterfs.so.0(_gf_msg+0x804) [0x7fdbc0ac7844] -->/usr/local/lib/libglusterfs.so.0(mem_get0+0x78) [0x7fdbc0af5b48] ) 0-mem-pool: invalid argument [Invalid argument]

Version-Release number of selected component (if applicable):
master

How reproducible:
Always

Steps to Reproduce:
1. Build glusterfs from master and start glusterd service
2. Execute any gluster command and check cli logs for the above mentioned error.

Actual results:
Error logs are seen.

Expected results:
No errors are seen.

Additional info:

Comment 1 Anand Avati 2015-07-16 08:56:39 UTC
REVIEW: http://review.gluster.org/11691 (cli: Create missing logbuf_pool) posted (#1) for review on master by Anoop C S (achiraya@redhat.com)

Comment 2 Anand Avati 2015-07-17 05:04:13 UTC
COMMIT: http://review.gluster.org/11691 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 4cdeee511ef8bab977cbb31bc2e8f005fe340ef1
Author: Anoop C S <anoopcs@redhat.com>
Date:   Thu Jul 16 13:56:51 2015 +0530

    cli: Create missing logbuf_pool
    
    Since logbuf_pool was not created via glusterfs_ctx_defaults_init(),
    the following error was present in cli logs repeateadly for each
    and every execution of a gluster command.
    
    E [mem-pool.c:417:mem_get0] (-->/usr/local/lib/libglusterfs.so.0(+0x7e262)
    [0x7fdbc0b1f262] -->/usr/local/lib/libglusterfs.so.0(_gf_msg+0x804)
    [0x7fdbc0ac7844] -->/usr/local/lib/libglusterfs.so.0(mem_get0+0x78)
    [0x7fdbc0af5b48] ) 0-mem-pool: invalid argument [Invalid argument]
    
    This change creates ctx->logbuf_pool via glusterfs_ctx_defaults_init()
    in cli.c so that the above error is no longer logged in cli logs.
    
    Change-Id: I3fcd9cfefa06ddd52e1989b039ff5637372c3235
    BUG: 1243753
    Signed-off-by: Anoop C S <anoopcs@redhat.com>
    Reviewed-on: http://review.gluster.org/11691
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 3 Nagaprasad Sathyanarayana 2015-10-25 15:21:49 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.


Note You need to log in before you can comment on or make changes to this bug.