Bug 124384 - Hang on boot solved by removing rhgb from grub.conf in FC 1
Hang on boot solved by removing rhgb from grub.conf in FC 1
Status: CLOSED DUPLICATE of bug 135574
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-26 02:28 EDT by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-05-26 02:28:34 EDT
Description of problem:
System freezes on every boot when graphical boot (rhgb) is used.  Most
often hangs just before X is lanched for login/password.  Solution is
to edit grub.conf to remove rhgb command.  Boots every time after that.


Version-Release number of selected component (if applicable):


How reproducible:
Boot hangs everytime with rhgb in grub.conf, works everytime with it
edited out.

Steps to Reproduce:
1.  Boot with rhgb in grub.conf -> hangs every time
2.  Boot with rhgb edited out of grub.conf -> boots every time
3.
  
Actual results:


Expected results:


Additional info:
I think this might be the solution to several reported bugs where
there have been hangs on booting.
Comment 1 André Johansen 2004-05-26 13:40:44 EDT
I can confirm this -- on my machine, FC1 hangs after xinetd is 
started when running with rhgb; when booting without it (by removing 
it from the kernel command line in Grub), it works fine (and 
sendmail starts up right after xinetd in that case). 
 
Comment 2 Daniel Veillard 2004-09-16 04:52:05 EDT
Is this still happening with a recent release like FC3t1 or
rawhide ? Can you give a bit more information about the hang,
can you switch to vt1 is this a kernel like crash ? Does
X starts okay on runlevel 5 ?

Daniel
Comment 3 Need Real Name 2004-10-10 21:21:22 EDT
Daniel-  It has been quite some time since this bug was submitted by
me, and since then I have moved on.  I'll have to answer your
questions by memory.

1. I have not tried FC3 in any iteration.
2. It was a kernal like crash--completely frozen system that required
a hard reboot (power recycle).
3. I have continued to use FC1 with patches.  The solution I've
proposed is still working with no freezes on boot.

Thanks for following up on this problem.  Maybe Andre (Add. Comment
#1) can add to the discussion.

-FW
Comment 4 Philip Van Hoof 2004-11-09 12:44:18 EST
Daniel: I would like to comment that not with Fedora Core 1, not with
Fedora Core 2 but WITH Fedora Core 3 I am having similar problems with
my Acer Travelmate 8000 laptop, which has a Radeon 9600 video card. 

Also, when I incorrectly shutdown the system (so that it will say
something about the mountpoints being incorrectly umounted bla bla),
it hangs while rhgb shows the label "Setting hostname".

When I did shutdown correctly, rhgb makes the keyboard and mouse stop
responding. When I login using the network, and try to restart X,
every piece of hardware stops resonding (total hardware crash).

When I disable rhgb, everything works perfectly. But I don't have a
nice bootup of course..
Comment 5 Philip Van Hoof 2004-11-09 12:47:13 EST
When I did shutdown correctly, rhgb makes the keyboard and mouse stop
responding. When I login using the network, and try to restart X,
every piece of hardware stops resonding (total hardware crash).

--> thats at the same postion of this bugreport. So between the switch
to the X-server that will run the Login Screen/Graphical greeter and
which will be used for your graphical session.
Comment 6 Christian Convey 2004-11-09 13:42:30 EST
I have to check this when I get home, but someone suggested that maybe
the following is the problem:

I upgraded from FC2 to FC3 today. When I'm booting, the process hangs
at "configuring kernel parameters".

Back in the FC2 days, I had nVidia's driver installed, and my
xorg.conf file properly reflected that.

So maybe this probelm stems from having a new kernel which doesn't yet
know about nVidia's driver, PLUS an xorg.conf file that refers to the
driver, PLUS rhgb relying on a properly-functioning xorg.conf file?
Comment 7 Glover George 2004-11-18 12:07:45 EST
This bug happens here as well, dell precision 650 / dual xeon 2.4ghz,
2gig memory, nvidia quadro pro card.  Our fix is to just remove the
rhgb option from grub, and restart.  Seen new updates today though for
rhgb and the kernel.  Maybe this fixes it.
Comment 8 Daniel Veillard 2004-11-19 11:41:56 EST

*** This bug has been marked as a duplicate of 135574 ***
Comment 9 Red Hat Bugzilla 2006-02-21 14:03:47 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.