Bug 1243846 - Neutron L3 agent HA doesn't get configured when using direct heat templates for provisioning
Summary: Neutron L3 agent HA doesn't get configured when using direct heat templates f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ga
: Director
Assignee: Dougal Matthews
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-16 12:58 UTC by Marius Cornea
Modified: 2015-08-05 13:59 UTC (History)
9 users (show)

Fixed In Version: python-rdomanager-oscplugin-0.0.8-39.el7ost
Doc Type: Bug Fix
Doc Text:
The Heat templates lacked a certain parameter to configure the Neutron L3 Agent. As a result the director would not configure the L3 Agent properly. This fix adds the missing Heat parameter to the templates. the director now configures the L3 Agent correctly.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:59:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 240062 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Marius Cornea 2015-07-16 12:58:53 UTC
Description of problem:
Neutron L3 agent HA doesn't get configured when using direct heat templates for provisioning.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.6-35.el7ost.noarch
openstack-heat-templates-0-0.6.20150605git.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy by passing ---use-tripleo-heat-templates:

openstack overcloud deploy --use-tripleo-heat-templates  --control-scale 3 --compute-scale 1 --ceph-storage-scale 0 --block-storage-scale 0 --swift-storage-scale 0 -e /usr/share/openstack-tripleo-heat-templates/environments/net-single-nic-with-vlans.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e /home/stack/network-environment.yaml --network-cidr 192.168.0.0/24 --floating-ip-cidr=172.16.23.0/24 --floating-ip-start=172.16.23.100 --floating-ip-end=172.16.23.150 --bm-network-gateway=172.16.23.251 --external-net-segmentation-id 10

2. 
[stack@instack ~]$ source overcloudrc
[stack@instack ~]$ neutron l3-agent-list-hosting-router default-router
+--------------------------------------+------------------------------------+----------------+-------+----------+
| id                                   | host                               | admin_state_up | alive | ha_state |
+--------------------------------------+------------------------------------+----------------+-------+----------+
| b908dd09-295f-4f0a-bc93-3a8c2335ecfb | overcloud-controller-2.localdomain | True           | :-)   |          |
+--------------------------------------+------------------------------------+----------------+-------+----------+
[stack@instack ~]$ ssh heat-admin@192.0.2.10 'sudo grep l3_ha /etc/neutron/neutron.conf'
# l3_ha = False
l3_ha = False
# l3_ha_net_cidr = 169.254.192.0/18

Actual results:
l3_ha is set to False

Expected results:
l3 ha should be configured.

Additional info:

Comment 4 Marius Cornea 2015-07-21 10:13:47 UTC
openstack overcloud deploy --control-scale 3 --compute-scale 1 -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e network-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/net-single-nic-with-vlans.yaml  --templates

source overcloudrc
 neutron net-create ext_net --provider:network_type vlan  --provider:physical_network  datacentre  --provider:segmentation_id 10  --router:external
 neutron  subnet-create ext_net --allocation-pool  start=172.16.23.110,end=172.16.23.150  --gateway 172.16.23.251 --cidr 172.16.23.0/24 --enable_dhcp=False
 neutron net-create tenant-net
 neutron subnet-create tenant-net 192.168.0.0/24 --name tenant-subnet --gateway 192.168.0.1
 neutron router-create  tenant-router
 neutron router-interface-add tenant-router tenant-subnet
 neutron router-gateway-set tenant-router ext_net

[stack@instack ~]$ neutron l3-agent-list-hosting-router tenant-router
+--------------------------------------+------------------------------------+----------------+-------+----------+
| id                                   | host                               | admin_state_up | alive | ha_state |
+--------------------------------------+------------------------------------+----------------+-------+----------+
| 038befaf-5aac-4b44-9dec-f0b344a2d061 | overcloud-controller-2.localdomain | True           | :-)   | standby  |
| 3fd57800-e6b2-49a2-9432-061da9546f6b | overcloud-controller-0.localdomain | True           | :-)   | standby  |
| 3cbe2f25-683d-4db4-aa01-d8223ee69914 | overcloud-controller-1.localdomain | True           | :-)   | standby  |
+--------------------------------------+------------------------------------+----------------+-------+----------+

[stack@instack ~]$ neutron l3-agent-list-hosting-router tenant-router
+--------------------------------------+------------------------------------+----------------+-------+----------+
| id                                   | host                               | admin_state_up | alive | ha_state |
+--------------------------------------+------------------------------------+----------------+-------+----------+
| 038befaf-5aac-4b44-9dec-f0b344a2d061 | overcloud-controller-2.localdomain | True           | :-)   | active   |
| 3fd57800-e6b2-49a2-9432-061da9546f6b | overcloud-controller-0.localdomain | True           | :-)   | standby  |
| 3cbe2f25-683d-4db4-aa01-d8223ee69914 | overcloud-controller-1.localdomain | True           | :-)   | standby  |
+--------------------------------------+------------------------------------+----------------+-------+----------+

Comment 6 errata-xmlrpc 2015-08-05 13:59:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.