Bug 124406 - Not booting services in parallell
Summary: Not booting services in parallell
Status: CLOSED DUPLICATE of bug 99540
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-26 11:51 UTC by Mikael Carneholm
Modified: 2014-03-17 02:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:03:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mikael Carneholm 2004-05-26 11:51:10 UTC
Description of problem:
Init should be replaced. Booting services sequentially is a slow
approach, and I would rather see something such as Seth's
SystemServices being used instead.

Additional info:
Another approach I've thought about, is to compile the service
starting procedure into a binary program (instead of the current
scripted solution) each time services are added/removed. Ie, using a
config file (a standard Makefile?) that is read by a compiler that
generates a binary program that is loaded instead of init. There
should however be a tool for configuring which services to start,
generating this config file - no manual textfile tweaking should be
necessary. Just an idea - but the booting procedure really needs to be
faster (XP boots in almost no time at all).

Comment 1 Bill Nottingham 2004-05-26 19:33:33 UTC

*** This bug has been marked as a duplicate of 99540 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:03:49 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.