Bug 124408 - switchdesk-gui fails when enlightenment is installed
switchdesk-gui fails when enlightenment is installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: switchdesk (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
: 137297 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-26 08:05 EDT by Stuart Children
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-26 11:42:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unified diff against switchdesk.glade to fix bug when enlightenment is installed. (1005 bytes, patch)
2004-05-26 08:06 EDT, Stuart Children
no flags Details | Diff

  None (edit)
Description Stuart Children 2004-05-26 08:05:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
If you have the enlightenment window manager installed then switchdesk
fails to run. This is caused by a typo in switchdesk.glade, which
results in the widget not being found when the Python tries to display
it. Fix is a simple patch (which I shall attach).




Version-Release number of selected component (if applicable):
switchdesk-4.0.3-1

How reproducible:
Always

Steps to Reproduce:
1. Install enlightenment window manager (eg: from
http://sourceforge.net/project/showfiles.php?group_id=2).
2. Ensure your DISPLAY is set to a valid X server.
3. Run `switchdesk`.

    

Actual Results:  hex ~ $ switchdesk
Red Hat Linux switchdesk 4.0
Copyright (C) 1999-2004 Red Hat, Inc
Redistributable under the terms of the GNU General Public License
Traceback (most recent call last):
  File "/usr/share/switchdesk/switchdesk-gui.py", line 207, in ?
    dlg = mainDialog().main()
  File "/usr/share/switchdesk/switchdesk-gui.py", line 87, in main
    self.hydrate()
  File "/usr/share/switchdesk/switchdesk-gui.py", line 150, in hydrate
    self.hydrate_wm()
  File "/usr/share/switchdesk/switchdesk-gui.py", line 169, in hydrate_wm
    self.xml.get_widget('enlightenmentRB').show()
AttributeError: 'NoneType' object has no attribute 'show'


Expected Results:  GTK-based switchdesk GUI should load, offering a
choice of Window Managers (including enlightenment) to use.



Additional info:
Comment 1 Stuart Children 2004-05-26 08:06:52 EDT
Created attachment 100578 [details]
Unified diff against switchdesk.glade to fix bug when enlightenment is installed.
Comment 2 Ngo Than 2004-05-26 11:42:51 EDT
it's fixed in 4.0.4-1. thanks for your report.
Comment 3 Ngo Than 2005-07-19 11:38:20 EDT
*** Bug 137297 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.