Bug 124410 - java hang on futex()
Summary: java hang on futex()
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libc   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-26 12:42 UTC by laurence duquesne
Modified: 2007-04-18 17:08 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-27 15:24:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description laurence duquesne 2004-05-26 12:42:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Java Swing Application with specific threads using JNI fonctions 
hangs on os::Linux::safe_cond_wait  (result of gcc)

The Swing IHM is completely frozen and the system uses 100% of CPU
The kill -3 on JVM doesn't work.

But the strace reveals that there is a stuck with NPTL futex. 
This NPTL futex is in glibc library.
The strace result is  : 
futex(0x8053048, FUTEX_WAIT, 0, NULL)

Version of java Hotspot 1.4.2_03-b02



Version-Release number of selected component (if applicable):
glibc-2 .3.2-11.9 , kernel-2.4.20.8

How reproducible:
Sometimes

Steps to Reproduce:
1.Launch the Swing application
2.Refresh frequently java IHM by passing xterm window
3.wait and have luck
    

Additional info:

Comment 1 Jakub Jelinek 2004-05-27 15:24:10 UTC
Red Hat Linux 9 is no longer supported and there have been important
NPTL fixes since then.  If you manage to reproduce this with Fedora Core 2 or RHEL3 U2,
please reopen.


Note You need to log in before you can comment on or make changes to this bug.