Bug 1244125 - [abrt] dnf: gettext.py:222:ugettext:UnicodeDecodeError: 'ascii' codec can't decode byte 0xe6 in position 0: ordinal not in range(128)
[abrt] dnf: gettext.py:222:ugettext:UnicodeDecodeError: 'ascii' codec can't d...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
22
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Kadlčík
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:ddd1c4c580108c28eae296bde15...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-17 04:30 EDT by Eric Li
Modified: 2015-08-19 03:51 EDT (History)
8 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.10-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-14 22:13:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.43 KB, text/plain)
2015-07-17 04:30 EDT, Eric Li
no flags Details
File: dso_list (105 bytes, text/plain)
2015-07-17 04:30 EDT, Eric Li
no flags Details
File: environ (3.03 KB, text/plain)
2015-07-17 04:30 EDT, Eric Li
no flags Details

  None (edit)
Description Eric Li 2015-07-17 04:30:43 EDT
Version-Release number of selected component:
dnf-1.0.1-2.fc22

Additional info:
reporter:       libreport-2.6.0
cmdline:        /usr/bin/python -OO /usr/bin/dnf copr enable mosquito/myrepo
executable:     /usr/bin/dnf
kernel:         4.0.7-300.fc22.i686
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
gettext.py:222:ugettext:UnicodeDecodeError: 'ascii' codec can't decode byte 0xe6 in position 0: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 185, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 134, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1077, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/copr.py", line 116, in run
    Do you want to continue? [y/N]: """)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/copr.py", line 185, in _ask_user
    answer = _(answer)
  File "/usr/lib/python2.7/gettext.py", line 222, in ugettext
    return unicode(message)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe6 in position 0: ordinal not in range(128)

Local variables in innermost frame:
message: '\xe6\x9c\xac\xe7\xaf\x87\xe6\x96\x87\xe7\xab\xa0\xe6\x9d\xa5\xe6\xba\x90\xe4\xba\x8e linux\xe5\x85\xac\xe7\xa4\xbe\xe7\xbd\x91\xe7\xab\x99(www.linuxidc.com)  \xe5\x8e\x9f\xe6\x96\x87\xe9\x93\xbe\xe6\x8e\xa5\xef\xbc\x9ahttp://www.linuxidc.com/linux/2015-05/118149.htmy'
self: <gettext.NullTranslations instance at 0xb570636c>
Comment 1 Eric Li 2015-07-17 04:30:49 EDT
Created attachment 1053013 [details]
File: backtrace
Comment 2 Eric Li 2015-07-17 04:30:51 EDT
Created attachment 1053014 [details]
File: dso_list
Comment 3 Eric Li 2015-07-17 04:30:52 EDT
Created attachment 1053015 [details]
File: environ
Comment 4 Radek Holy 2015-07-17 06:45:48 EDT
Looks like a problem in the Copr plugin.
Comment 5 Miroslav Suchý 2015-07-22 08:08:41 EDT
Jakube can you take it please?
Comment 6 Jakub Kadlčík 2015-07-27 06:54:58 EDT
I am confirming that it is an issue in copr plugin.

Please note that the issue is not related to `mosquito/myrepo` at all.

Steps to reproduce:
1. sudo dnf copr enable mosquito/myrepo  # Or another <user>/<copr>
2. Type "ěščřžýáíé" as an answer for "Do you want to continue? [y/N]:"

Expected results:
It should ask same question again. Like when you answer whatever else instead of "y" or "n".
Comment 7 Jakub Kadlčík 2015-07-27 10:09:56 EDT
Modified in: 36bacb6
Comment 8 Fedora Update System 2015-08-10 06:05:41 EDT
dnf-plugins-core-0.1.10-1.fc23,dnf-1.1.0-1.fc23,hawkey-0.6.0-1.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.10-1.fc23,dnf-1.1.0-1.fc23,hawkey-0.6.0-1.fc23
Comment 9 Fedora Update System 2015-08-10 06:49:19 EDT
dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22
Comment 10 Fedora Update System 2015-08-10 22:10:33 EDT
Package dnf-plugins-core-0.1.10-1.fc22, dnf-1.1.0-1.fc22, hawkey-0.6.0-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.10-1.fc22 dnf-1.1.0-1.fc22 hawkey-0.6.0-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13162/dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2015-08-14 22:13:41 EDT
dnf-plugins-core-0.1.10-1.fc22, hawkey-0.6.0-1.fc22, dnf-1.1.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2015-08-19 03:51:30 EDT
dnf-plugins-core-0.1.10-1.fc23, hawkey-0.6.0-1.fc23, dnf-1.1.0-2.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.