Bug 124414 - Nautilus shows odd desktop icons when manually changing fstab
Nautilus shows odd desktop icons when manually changing fstab
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-26 09:22 EDT by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-28 15:33:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-05-26 09:22:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
After installing FC2 I changed /etc/fstab (to be able to write to vfat
filesystems as unprivileged user and to be able to mount my digital
camera). Then I rebooted and Nautilus added the mount points as icons
to my desktop. I don't understand this behaviour, volume icons should
be (they are too!) in the 'Computer' folder. Can I sweep them somehow?

But that's not all, the icons on the desktop (all of them) show with
the not-writeable sub-icon (stroken pencil), but I can still
read/write to them!

The properties dialog of the 'Home' folder tells me I cannot change
the rights because I'm not its owner! I can change the permissions
bits in the same dialog, though. Doing so doesn't affect the icon
(still shows the with stroken pencil)

The properties dialog of the 'Computer' tells me that the owner of the
file is root...?


Version-Release number of selected component (if applicable):
2.6.0-4

How reproducible:
Always

Steps to Reproduce:
1. manually change fstab options
2. reboot


Actual Results:  Odd desktop icons and other Nautilus behaviour.

Expected Results:  Nothing changes on my desktop!

Additional info:

my fstab listing:

                                                                     
       LABEL=/          /               ext3    defaults        1 1
none             /dev/pts        devpts  gid=5,mode=620  0 0
none             /dev/shm        tmpfs   defaults        0 0
/dev/hda8        /mnt/data       vfat   
rw,owner,auto,showexec,codepage=852,iocharset=utf8,umask=000,quiet   
    0 0
LABEL=/mnt/data1 /mnt/data-ext3  ext3    defaults        1 2
/dev/hda1        /mnt/windows    vfat   
rw,owner,auto,showexec,codepage=852,iocharset=utf8,umask=000,quiet   
    0 0
none             /proc           proc    defaults        0 0
none             /sys            sysfs   defaults        0 0
/dev/hda7        swap            swap    defaults        0 0
/dev/cdrom       /mnt/cdrom      udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0         /mnt/floppy     auto    noauto,owner,kudzu 0 0
/dev/sda1        /mnt/camera     vfat    rw,user,noauto,noexec  0 0
Comment 1 Need Real Name 2004-05-26 12:39:06 EDT
Newly created users don't have the silly pencils on their icons!
Erasing config files or recreating my account doesn't help.
This fact shows that I probably screwed something up. Any suggestions?
Comment 2 Need Real Name 2004-05-28 04:44:58 EDT
Newly created users get the stupid icons after shutdown too. I'm
really getting annoyed about this. Reminds me MS Windows somehow:(
Comment 3 Need Real Name 2004-05-28 15:33:48 EDT
OK, it seems I have workarounds:

To make the mounpoints disappear from the desktop I changed some flags
in fstab from:

rw,owner,auto,showexec,codepage=852,iocharset=utf8,umask=000,quiet

to:

showexec,codepage=852,iocharset=utf8,posix,umask=000,quiet

which also works for me.

To prevent the stroken pencils from showing over the desktop icons, it
is necessary to NOT include the user into the 'root' group.

Note You need to log in before you can comment on or make changes to this bug.