Bug 1244188 - Can't connect to WPA Enterprise wireless connections
Summary: Can't connect to WPA Enterprise wireless connections
Keywords:
Status: CLOSED DUPLICATE of bug 1241930
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-nm
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-17 12:31 UTC by Germano Massullo
Modified: 2015-09-11 09:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-11 09:55:33 UTC


Attachments (Terms of Use)
screenshot (33.24 KB, image/jpeg)
2015-07-17 12:31 UTC, Germano Massullo
no flags Details


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 352377 None None None Never

Description Germano Massullo 2015-07-17 12:31:13 UTC
Description of problem:
Hi Jan, we have already spoken about F22 Plasma 5 that cannot connect to WPA Enterprise wireless connections. We did some tests disabling and enabling the KWallet, but I am still prompted for "a password" (see screenshot) even if I filled the wireless connection settings with proper user, password and security protocol

Version-Release number of selected component (if applicable):
plasma-nm-5.3.2-1.fc22.x86_64

Comment 1 Germano Massullo 2015-07-17 12:31:40 UTC
Created attachment 1053061 [details]
screenshot

Comment 2 Germano Massullo 2015-07-17 13:09:13 UTC
wpa_supplicant-2.4-3.fc22.x86_64

Comment 3 koraq 2015-07-17 13:45:29 UTC
I have had a similar problem, and I have managed to get WPA Enterprise to work, but only with wpa_supplicant-2.3-3 if that might be of some help narrowing down the problem.

Comment 4 Germano Massullo 2015-07-24 14:15:07 UTC
I tried starting NM with command

NetworkManager --debug --log-level=DEBUG
then I collected logs at https://mega.co.nz/#F!Z5IhnJDB!kOCtd7-Aqpw53MlEIjURMw

I am sorry for using a third party upload host, but the logs could contain some remaining sensitive data and I need to be able to edit/erase them.

The affected connection is "eduroam".
I also do not understand why NM is trying to connect to "Tib House" that is a wireless connection that is not available at all

Comment 5 Jan Grulich 2015-08-03 12:31:13 UTC
This is interesting, according to NM log it succeeded to get password from KWallet (our secret agent), but it doesn't get activated due to "new-activation", which means you or NM tried to activate a different connection right after activation of your eduroam connection.

Comment 6 Germano Massullo 2015-09-07 10:27:34 UTC
Opened an upstream bugreport because I have a friend using Kubuntu that experience the same problem

Comment 7 Fabio Alessandro Locati 2015-09-08 16:01:47 UTC
I'm able to connect to eduroam networks without problems with KDE and F22... maybe is something else?

Comment 8 Germano Massullo 2015-09-11 09:55:33 UTC

*** This bug has been marked as a duplicate of bug 1241930 ***


Note You need to log in before you can comment on or make changes to this bug.