Bug 1244226 - allow_overlapping_ips should be enabled by default
Summary: allow_overlapping_ips should be enabled by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: Director
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ga
: Director
Assignee: Jiri Stransky
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-17 13:47 UTC by Attila Darazs
Modified: 2015-08-05 13:59 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-heat-templates-0.8.6-44.el7ost
Doc Type: Bug Fix
Doc Text:
Prior to this release, the allow_overlapping_ips Neutron setting was left at default. As a consequence, allow_overlapping_ips in Neutron was disabled, preventing definition of multiple networks with the same ranges. This problem has been fixed by setting allow_overlapping_ips to "true", and as a result, networks with overlapping ranges can be defined.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:59:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 203020 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Attila Darazs 2015-07-17 13:47:08 UTC
Description of problem:
In /etc/neutron/neutron.conf we have

allow_overlapping_ips = False

This is not optimal for a default neutron installation and breaks tempest tests that assume this is the default.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.6-43.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud with default settings
2. check /etc/neutron/neutron.conf

Actual results:
False

Expected results:
True

Comment 3 Jiri Stransky 2015-07-17 14:00:51 UTC
Patch tested upstream:

[root@overcloud-controller-0 ~]# grep ^allow_overlapping_ips /etc/neutron/neutron.conf
allow_overlapping_ips = True

[root@overcloud-novacompute-0 ~]# grep ^allow_overlapping_ips /etc/neutron/neutron.conf
allow_overlapping_ips = True

Comment 5 Itzik Brown 2015-07-20 12:18:41 UTC
Checked with openstack-tripleo-heat-templates-0.8.6-44.el7ost.noarch

Comment 7 errata-xmlrpc 2015-08-05 13:59:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.