Bug 124425 - airo "MAC could not be enabled" with an Aironet 340 PCI card
airo "MAC could not be enabled" with an Aironet 340 PCI card
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-26 10:26 EDT by AJ Bostian
Modified: 2015-01-04 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-26 13:47:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg and lsmod output (1.91 KB, text/plain)
2004-05-26 10:28 EDT, AJ Bostian
no flags Details

  None (edit)
Description AJ Bostian 2004-05-26 10:26:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040510

Description of problem:
I am trying to configure an Aironet 340 PCI wireless card.  I'm
running kernel-2.6.5-1.358 (default that shipped with FC2).  My
network adapters are a Realtek 8139 ethernet card and the Aironet 340
wireless card.

It appears that the airo module initially loads fine, but then it is
unregistered right before the 8139too module loads.  airo then reloads
after 8139too loads, but it now gives a "MAC could not be enabled"
error.  I get a "airo device eth1 does not appear to be present"
message when I attempt to bring up eth1 manually using the network
init script.

I will attach the parts of dmesg and lsmod pertaining to networking items.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Load 8139too and airo modules on boot.
2.
3.
    

Additional info:
Comment 1 AJ Bostian 2004-05-26 10:28:12 EDT
Created attachment 100587 [details]
dmesg and lsmod output
Comment 2 Dejan Kolar 2004-06-01 11:39:58 EDT
I'm also having these problems with my cisco340 PCI card. I've tried
it with new kernel also 2.6.6 but with the same results.

With RH9.0 I did also have that problem but as soon I deployed a new
kernel 2.4.26 it started to work prefectly no mather what firmware was
in Airo340 PCI card.

Looks like Fedora isn't quite stable version and behaves like beta.
Comment 3 AJ Bostian 2004-06-01 12:02:29 EDT
Funny, because the patch to 2.4.26 contains the comment

Summary of changes from v2.4.25 to v2.4.26-pre1
============================================
snip...
  o [wireless airo] backport 2.6.x cleanups/minor fixes
  o [wireless airo] fix build breakage

So it looks like whatever was implemented in 2.6 development breaks in
2.6 but works ok in 2.4.26.
Comment 4 Dejan Kolar 2004-06-01 12:13:16 EDT
So what should be done, bring up Fedora under 2.4.26 ? I think that is
not an issue for Fedora developpes...
Or should we just wait and see if something brings up...
Comment 5 AJ Bostian 2004-06-01 13:01:20 EDT
Fortunately, I'm not in a situation where my only choice for a pipe to
the Internet is wireless, so I'm just going to hope that someone takes
the bug.  But, if you're in an environment where you need this card, I
guess your only choice is to downgrade to 2.4.26 for now and hope for
the best later.

Many educational institutions (such as the University of Virginia
where I'm at) have standardized on Cisco wireless, so it would be a
shame not to have this functionality available in Fedora.
Comment 6 AJ Bostian 2004-06-05 10:45:43 EDT
I just verified the same result using several 4.x versions of the
Aironet 340 firmware.  (There was a substantial redesign between the
4.x and the 5.x firmware as I recall, and I don't believe the airo
module supports 5.x firmware yet.)  I think the airo module is just
borked.
Comment 7 AJ Bostian 2004-06-16 10:28:01 EDT
Unfortunately still broken under kernel-2.6.6-1.435.
Comment 8 Dejan Kolar 2004-06-16 10:36:08 EDT
There is a workarround, exclude kudzu in startup and everuthing works
fine. It seems like kudzu is broken...
Comment 9 AJ Bostian 2004-06-16 12:21:25 EDT
Sure enough, that worked.  I guess this bug goes to the kudzu guys...
Comment 10 Matthew Miller 2005-04-26 11:54:21 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 11 AJ Bostian 2005-04-26 12:28:09 EDT
Fixed in FC3.

Note You need to log in before you can comment on or make changes to this bug.