Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1244348 - Quirk for Chelsio T5 MSI-X PBA
Summary: Quirk for Chelsio T5 MSI-X PBA
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Alex Williamson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1244347
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-17 20:36 UTC by Alex Williamson
Modified: 2015-12-04 16:52 UTC (History)
8 users (show)

Fixed In Version: qemu-kvm-rhev-2.3.0-13.el7
Doc Type: Bug Fix
Doc Text:
Clone Of: 1244347
Environment:
Last Closed: 2015-12-04 16:52:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description Alex Williamson 2015-07-17 20:36:00 UTC
+++ This bug was initially created as a clone of Bug #1244347 +++

Description of problem:
Chelsio T5 adapters incorrectly list the MSI-X Pending Bit Array (PBA) table at an offset beyond the PCI BAR containing it.  The guest does not use the PBA, but vfio does as part of mapping device regions for the guest.  When attempting to assign one of these devices to a VM, the call to msix_init() will fail due to this inconsistency.  A quirk has been added to the QEMU vfio-pci driver correct this problem in the case of a Chelsio T5 adapter and error with a useful message indicating a hardware problem in the general case.


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Attempt to assign Chelsio T5 to a guest
2.
3.

Actual results:
Device fails to attach on hot plug, VM startup failure on cold plug (presumably, we don't have any)

Expected results:
Device attaches/VM starts

Additional info:
Upstream patch:
http://git.qemu.org/?p=qemu.git;a=commitdiff;h=43302969966bc3a95470bfc300289a83068ef5d9

Comment 4 Miroslav Rezanina 2015-07-24 11:09:06 UTC
Fix included in qemu-kvm-rhev-2.3.0-13.el7

Comment 7 juzhang 2015-08-03 03:46:09 UTC
According to comment6, set this issue as verified.

Comment 9 errata-xmlrpc 2015-12-04 16:52:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.