Bug 124448 - vnc-4.0-1.beta5.1 takes down the kernel
vnc-4.0-1.beta5.1 takes down the kernel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-26 13:00 EDT by mark
Modified: 2015-01-04 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-14 20:14:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mark 2004-05-26 13:00:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040514

Description of problem:
on Fedora Core 2 (updated with rawhide) with kernel 2.6.6-1.368...

VNC is not only hanging the Xserver but the linux kernel as well!

i'm trying to connect using vnc from chrisf53 (192.168.2.5) to markf78
(192.168.2.2). i've opened ports 5900 and 5901 in the firewall on 
markf78 to allow vnc traffic to enter.

selinux is disabled in both systems.

[root@chrisf53 root]# rpm -qa | grep vnc*
vnc-4.0-1.beta5.1

[root@markf78 root]# rpm -qa | grep vnc*
vnc-4.0-1.beta5.1
vnc-server-4.0-1.beta5.1

in my /etc/X11/xorg.conf on "markf78", i added:

Load  "vnc" to Section "Module"
Option "passwordFile" "/root/.vnc/passwd" to Section "Screen"

[root@markf78 root]# more /etc/sysconfig/vncservers
# The VNCSERVERS variable is a list of display:user pairs.
#
# Uncomment the line below to start a VNC server on display :1
# as my 'myusername' (adjust this to your own).  You will also
# need to set a VNC password; run 'man vncpasswd' to see how
# to do that.
#
# DO NOT RUN THIS SERVICE if your local area network is
# untrusted!  For a secure way of using VNC, see
# <URL:http://www.uk.research.att.com/vnc/sshvnc.html>.
 
VNCSERVERS="1:root"
VNCSERVERARGS[1]="-geometry 800x600"
[root@markf78 root]#

[root@chrisf53 root]# vncviewer 192.168.2.2
 
VNC viewer for X version 4.0b5 - built May 20 2004 10:53:23
Copyright (C) 2002-2004 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
 
Fri May 21 22:31:26 2004
 CConn:       connected to host 192.168.2.2 port 5900
 CConnection: Server supports RFB protocol version 3.7
 CConnection: Using RFB protocol version 3.7
 
Fri May 21 22:31:35 2004
 TXImage:     Using default colormap and visual, TrueColor, depth 16.
 CConn:       Using pixel format depth 6 (8bpp) rgb222
 CConn:       Using ZRLE encoding

(system crashes including kernel)

[root@chrisf53 root]# ssh 192.168.2.2
ssh: connect to host 192.168.2.2 port 22: No route to host
[root@chrisf53 root]# ping 192.168.2.2
PING 192.168.2.2 (192.168.2.2) 56(84) bytes of data.
From 192.168.2.5 icmp_seq=0 Destination Host Unreachable
From 192.168.2.5 icmp_seq=1 Destination Host Unreachable
From 192.168.2.5 icmp_seq=2 Destination Host Unreachable
 
--- 192.168.2.2 ping statistics ---
3 packets transmitted, 0 received, +3 errors, 100% packet loss, time
2006ms
, pipe 4

btw, i forgot to mention that i altered my XF86Config to parallel the
changes in xorg.conf due to "http://www.realvnc.com/v4/x0.html"
(outdated???) although i am assuming this file is now ignored with the
transition to xorg. 



Version-Release number of selected component (if applicable):
kernel 2.6.6-1.368

How reproducible:
Always

Steps to Reproduce:
1.see description
2.
3.
    

Additional info:
Comment 1 Dave Jones 2004-11-02 22:47:29 EST
is this still a problem in current kernels ?
Comment 2 mark 2004-11-03 01:48:45 EST
since the advansys scsi module hasn't been included in recent kernels,
i'm stuck at kernel-2.6.6-1.435.2.3 and unable to provide more info at
the moment...
Comment 3 mark 2005-07-14 20:14:31 EDT
this is not an issue in FC4... sorry about the delay in responding

Note You need to log in before you can comment on or make changes to this bug.