Bug 1244486 - [doc] Add yum vs dnf hooks information in dnf documentation
[doc] Add yum vs dnf hooks information in dnf documentation
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-19 03:25 EDT by Parag Nemade
Modified: 2015-08-19 03:51 EDT (History)
7 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.10-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-14 22:13:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2015-07-19 03:25:00 EDT
Description of problem:
We have yum hooks information -> http://yum.baseurl.org/wiki/WritingYumPlugins

We have dnf hooks information ->  http://dnf.readthedocs.org/en/latest/api_plugins.html

We need documentation like if there is any similar hook in dnf compared to yum. Also, any difference if both have similar hooks but different functionality.

I tried to prepare https://fedoraproject.org/wiki/User:Pnemade/dnf-hooks page but dnf developers are best people to add this information in upstream dnf documentation.
Comment 1 Radek Holy 2015-07-20 03:02:43 EDT
I'd just note that DNF API was never meant to be similar to YUM API. Such comparison may be misleading then. But I admit that the hook documentation can be richer. I mean, I'd use same words which are used in YUM's documentation rather then mentioning the YUM hooks in DNF's documentation. If we would refer to YUM hooks, other users may ask for similar comparison of other DNF functions later and in the end it may be totally confusing since we will be receiving reports like "You claim that this function/hook is similar to this YUM function/hook. I used to do this but it does not work with DNF despite the fact the it should be similar.".
Comment 2 Honza Silhan 2015-07-29 11:20:21 EDT
Parag, can you make a pull request to DNF with this table in new page "api_vs_yum.rst", please?
Comment 3 Parag Nemade 2015-07-30 07:13:56 EDT
Submitted https://github.com/rpm-software-management/dnf/pull/324
Comment 4 Fedora Update System 2015-08-10 06:05:49 EDT
dnf-plugins-core-0.1.10-1.fc23,dnf-1.1.0-1.fc23,hawkey-0.6.0-1.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.10-1.fc23,dnf-1.1.0-1.fc23,hawkey-0.6.0-1.fc23
Comment 5 Fedora Update System 2015-08-10 06:49:32 EDT
dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22
Comment 6 Fedora Update System 2015-08-10 22:10:46 EDT
Package dnf-plugins-core-0.1.10-1.fc22, dnf-1.1.0-1.fc22, hawkey-0.6.0-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.10-1.fc22 dnf-1.1.0-1.fc22 hawkey-0.6.0-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13162/dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2015-08-14 22:13:33 EDT
dnf-plugins-core-0.1.10-1.fc22, hawkey-0.6.0-1.fc22, dnf-1.1.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2015-08-19 03:51:37 EDT
dnf-plugins-core-0.1.10-1.fc23, hawkey-0.6.0-1.fc23, dnf-1.1.0-2.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.