Bug 1244531 - "langpacks: No languages are enabled" every time dnf is run
Summary: "langpacks: No languages are enabled" every time dnf is run
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-langpacks
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Parag Nemade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-19 18:55 UTC by Jonathan Kamens
Modified: 2015-07-29 01:48 UTC (History)
6 users (show)

Fixed In Version: dnf-langpacks-0.12.0-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-29 01:48:42 UTC


Attachments (Terms of Use)

Description Jonathan Kamens 2015-07-19 18:55:44 UTC
With a default F22 installation updated from updates-testing, I get "langpacks: No languages are enabled" every time I run dnf. Boy, is this annoying and useless. I also get "langpacks: enabled languages are []" later in the dnf output.

Please make this go away.

Comment 1 Parag Nemade 2015-07-20 03:15:07 UTC
Okay I will make them not to appear. Give me some time before existing update pushed to stable. I will submit another update.

The reason I enabled them is to make sure langpacks plugin user will get instant same time information about langpacks installed on the system. Otherwise they will need to do some extra commands/things to find which languages are enabled on their system.

Comment 2 Christian Stadelmann 2015-07-20 07:21:16 UTC
I think it would be better to tell the user to edit /etc/dnf/plugins/langpacks.conf. After that there is still some more text displayed every time you start dnf, which should go away.

Comment 3 Parag Nemade 2015-07-20 07:25:38 UTC
yes all those messages coming from langpacks plugin will go away but first let the existing update be moved to stable. Looks like some releng issue going on that is why neither rawhide report generated yesterday nor broken dependencies report and even no updates push happening.

Comment 4 Kostya Vasilyev 2015-07-21 14:07:53 UTC
Also getting these with dnf-langpacks.noarch 0.11.1-1.fc22 and dnf 1.0.1-2.fc22

langpacks: No languages are enabled
Last metadata expiration check performed 0:01:32 ago on Tue Jul 21 17:02:56 2015.
Dependencies resolved.
langpacks: enabled languages are []
Nothing to do.
Complete!

The ones from langpacks:

langpacks: No languages are enabled

and

langpacks: enabled languages are []

look like debug output, they're annoying, please remove.

The output from dnf itself (expiration check, dependencies, nothing to do, "complete!") actually tell me something. The output from langpacks doesn't.

Comment 5 Fedora Update System 2015-07-21 15:20:55 UTC
dnf-langpacks-0.12.0-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-langpacks-0.12.0-2.fc22

Comment 6 Parag Nemade 2015-07-21 17:20:43 UTC
All,
  I have submitted new update now that moved extra info messages to debug messages. Please test and give karma accordingly.

Comment 7 Gerald Cox 2015-07-22 18:47:20 UTC
I'm a little concerned, not so much by the message itself, but rather the impact this change seemed to have on running fedora-review.  Note the output below:

Package does not own files or directories owned by other packages.
Note: Dirs in package are owned also by:
/usr/lib/gap/pkg/aclib/gap(languages, langpacks:, enabled, are, No),
/usr/lib/gap/pkg/aclib/htm(languages, langpacks:, enabled, are, No),
/usr/lib/gap/pkg/aclib/doc(languages, langpacks:, enabled, are, No),
/usr/lib/gap/pkg/aclib(languages, langpacks:, enabled, are, No)

When I applied the update in #c5 that appeared to resolve the false positive, however I'm getting some weird results regarding package ownership on other projects which didn't occur before.  I need to run some more tests to confirm, but I wanted to make you aware that whatever this change did, it appears to have had a negative impact on other applications, specifically, fedora-review.

Comment 8 Parag Nemade 2015-07-23 04:26:43 UTC
Gerald,
Sorry but I don't understand howcome dnf langpacks plugin changing the fedora-review behaviour.

I too ran fedora-review on your reviewed package gap-pkg-aclib but could not find those messages. I even grep for word "langpack" in the fedora-review output directory and still no line get searched.
See https://pnemade.fedorapeople.org/1233989-gap-pkg-aclib/

I can't reproduce what you saw on your machine :)

Now about the output you pasted above let's look at fedora-review source code. From https://git.fedorahosted.org/cgit/FedoraReview.git/tree/plugins/generic.py#n1151 line it says the directories that are created by a package is already owned by some other packages. This need to be discussed among those other package owners that who should own the directory actually.

Comment 9 Gerald Cox 2015-07-23 05:10:06 UTC
(In reply to Parag from comment #8)
> Gerald,
> Sorry but I don't understand howcome dnf langpacks plugin changing the
> fedora-review behaviour.
> 
> I too ran fedora-review on your reviewed package gap-pkg-aclib but could not
> find those messages. I even grep for word "langpack" in the fedora-review
> output directory and still no line get searched.
> See https://pnemade.fedorapeople.org/1233989-gap-pkg-aclib/
> 
> I can't reproduce what you saw on your machine :)
> 
> Now about the output you pasted above let's look at fedora-review source
> code. From
> https://git.fedorahosted.org/cgit/FedoraReview.git/tree/plugins/generic.
> py#n1151 line it says the directories that are created by a package is
> already owned by some other packages. This need to be discussed among those
> other package owners that who should own the directory actually.

Thanks for taking a look... all I can say is that if you look at the error that
was reported by fedora-review above, i.e.:
/usr/lib/gap/pkg/aclib/gap(languages, langpacks:, enabled, are, No),

you can see it says:  (languages, langpacks:, enabled, are, No) which in and of itself is completely weird.

I then did a search on that which brought me to this bug.  I then applied the update mentioned in #C5 and the problem disappeared.  

Something definitely was or is going on.

Comment 10 Parag Nemade 2015-07-23 05:15:44 UTC
Thanks for quick reply. If you still found those messages in any fedora-review output, please tell me here and I would like to have a look at it. 

Also, its strange that the actual log messages appearing was "langpacks: No languages are enabled" whereas what you found is like words collected from "langpacks: No languages are enabled" and was randomly printed there.

Comment 11 Gerald Cox 2015-07-23 05:23:34 UTC
Just for clarification, I was running:
dnf-langpacks.noarch 0.11.1-1.fc22

when I had the issue.  The problem appears to be corrected in:
dnf-langpacks.noarch 0.12.0-2.fc22

What version of dnf-langpacks where you running for the test?

Comment 12 Gerald Cox 2015-07-23 05:26:02 UTC
(In reply to Parag from comment #10)
> Thanks for quick reply. If you still found those messages in any
> fedora-review output, please tell me here and I would like to have a look at
> it. 
> 
> Also, its strange that the actual log messages appearing was "langpacks: No
> languages are enabled" whereas what you found is like words collected from
> "langpacks: No languages are enabled" and was randomly printed there.

Will do - and thanks again for taking the time to look into it.

Comment 13 Parag Nemade 2015-07-23 05:59:02 UTC
(In reply to Gerald Cox from comment #11)
> Just for clarification, I was running:
> dnf-langpacks.noarch 0.11.1-1.fc22
> 
> when I had the issue.  The problem appears to be corrected in:
> dnf-langpacks.noarch 0.12.0-2.fc22
> 
> What version of dnf-langpacks where you running for the test?

I am using dnf-langpacks.noarch 0.12.0-2.fc22 build. 

To test your issue, lets use f22 mock config which is having dnf-langpacks-0.12.0-1.fc22.noarch build. I ran fedora-review and again no results for "langpack" word in fedora-review output directory. 

I then realized that in mock dnf-langpacks is not at all getting used/installed. Just check root.log and you will not find dnf-langpacks. So, I conclude that dnf-langpacks is never used in mock builds as there is no explicit package pulling it into buildroot.

Comment 14 Gerald Cox 2015-07-23 15:48:20 UTC
(In reply to Parag from comment #13)
> (In reply to Gerald Cox from comment #11)
> > Just for clarification, I was running:
> > dnf-langpacks.noarch 0.11.1-1.fc22
> > 
> > when I had the issue.  The problem appears to be corrected in:
> > dnf-langpacks.noarch 0.12.0-2.fc22
> > 
> > What version of dnf-langpacks where you running for the test?
> 
> I am using dnf-langpacks.noarch 0.12.0-2.fc22 build. 
> 
> To test your issue, lets use f22 mock config which is having
> dnf-langpacks-0.12.0-1.fc22.noarch build. I ran fedora-review and again no
> results for "langpack" word in fedora-review output directory. 
> 
> I then realized that in mock dnf-langpacks is not at all getting
> used/installed. Just check root.log and you will not find dnf-langpacks. So,
> I conclude that dnf-langpacks is never used in mock builds as there is no
> explicit package pulling it into buildroot.

As I previously mentioned the problem doesn't appear in with 0.12.0-2.  If you want to recreate it and discover what had happened you need to use 0.11.1-1
I just downgraded to 0.11.1-1 and the issue returned.  I then went back to 0.12.0-2 and the issue disappeared.

Comment 15 Parag Nemade 2015-07-23 16:25:22 UTC
Ah my bad, downgrading to 0.11.1-1 version, I can reproduced it. I will check further how the log message words appeared in review.txt. But with the latest update there will not be any issue for fedora-review.

Comment 16 Fedora Update System 2015-07-29 01:48:42 UTC
dnf-langpacks-0.12.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.