Bug 124468 - Creating a default user make some unfortunate assumptions on file and directory owner and group membership as well as access priviledges...
Creating a default user make some unfortunate assumptions on file and directo...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-26 16:13 EDT by Carsten Klein
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-27 00:33:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carsten Klein 2004-05-26 16:13:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030917

Description of problem:

I hope this is the correct component I am posting this bug to.

After installing Fedora Core 2 I was prompted to create a new user for
every day use. I did this and found that access priviledges for shared
devices such as the sound card's sequencer and others were incorrectly
set or at least were set as such that possible other users (not root)
may not access or use the sound facility of the system.

-- snip --

Futhermore I have found that all the sound devices in /dev/ and
/dev/snd have an odd security policy, that is, the owner is the single
user I have created when first booting the system after installation
and the group is set to root. I'd rather like it to be root/users with
access modes set to 660 instead of 600 as it is now.

Here is a sample output for /dev/sequencer and /dev/dsp

crw-------  1 rts root 14, 3 23. Feb 22:02 /dev/dsp
crw-------  1 rts root 14, 3 23. Feb 22:02 /dev/sequencer

I wonder why you did that instead of 


crw-rw----  1 root users 14, 3 23. Feb 22:02 /dev/dsp


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try (this would have involved re-installation of FC2)

Steps to Reproduce:
1. Install FC2
2. Create user for every day work
3. ls -al /dev/* | grep <userid of the above created user>
    

Actual Results:  The newly created user is the _owner_ of the device
files in /dev/ and is the only one being granted read and write
permission on these devices. The group is set to 'root' and both group
and others do not have any access permission.

Expected Results:  The newly created user should be added to the
'users' group and the devices in question should be owned by that
group and user root. Access permissions should be set to 660 in case
casual users of Linux would want to create more users and use them in
conjunction with the user they created after first install of Fedora.

Additional info:

As it is of now, users that do not have a technical background will
fail to create new users and use sound or other devices due to the
restrictions made by the installation tool.
Comment 1 Carsten Klein 2004-05-27 00:33:28 EDT
Forget that, artsd creates those devices on startup and naturally
assigns the user's user id as owner to these devices as it is started
in the context of the user running the X-session.

How could I even come to think that it would be otherwise? Must have
been late...

Note You need to log in before you can comment on or make changes to this bug.