Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1244690

Summary: Satellite upgrade is throwing errors of 'no type definition found for docker_image'
Product: Red Hat Satellite Reporter: Jitendra Yejare <jyejare>
Component: UpgradesAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED CURRENTRELEASE QA Contact: Jitendra Yejare <jyejare>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.1.0CC: chpeters, cwelton, mmccune, sghai, stbenjam
Target Milestone: UnspecifiedKeywords: Reopened
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-08-12 16:04:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1195450    
Attachments:
Description Flags
Satellite Foreman-Debug
none
Katello-installer Logs none

Description Jitendra Yejare 2015-07-20 09:49:26 UTC
Created attachment 1053802 [details]
Satellite Foreman-Debug

Description of problem:
Satellite upgrade from 6.0.8 to latest Sat GA snap 13 C2, throwing an error message of 'no type definition found for docker_image'.

Version-Release number of selected component (if applicable):
Satellite GA snap 13 C2.

How reproducible:

Pre-condition:
Satellite 6.0.8 with capsule and at least one host configured.

Steps to Reproduce:
1. Upgrade Satellite 6.0.8 to latest GA snap 13 C2.
2. Observe the /var/log/messages when satellite upgrade is in process.


Actual results:
The following error message has been displayed under /var/log/messages:
Jul 20 04:40:54 sat6-qe-rhel66 pulp: pulp.server.initialization:ERROR: One or more plugins failed to initialize. If a new type has been added, run pulp-manage-db to load the type into the database and restart the application. Error message: Importer docker_importer: no type definition found for docker_image


Expected results:
No error logs.

Additional info:

Comment 1 Jitendra Yejare 2015-07-20 09:50:41 UTC
Created attachment 1053803 [details]
Katello-installer Logs

Comment 3 Stephen Benjamin 2015-07-22 10:41:46 UTC
Same issue, fix should be in SNAP14.

*** This bug has been marked as a duplicate of bug 1228694 ***

Comment 4 Mike McCune 2015-07-22 14:50:12 UTC
This is fixed with the PR for: 

https://bugzilla.redhat.com/show_bug.cgi?id=1228694

but since this is for the Satellite vs Capsule we are tracking both.

Comment 6 Sachin Ghai 2015-07-30 06:54:33 UTC
The reported issue is no longer reproducible on satellite server while upgrading the server from sat6.0.8 to sat6.1.1 GA snap15.

Comment 7 Jitendra Yejare 2015-07-30 11:03:44 UTC
Verified this issue on latest Satellite GA snap 15.

Observed the /var/log/messages on satellite while upgrading Satellite 6.0.8 to Sat 6.1 GA snap 15.

The is no more reproducible and seems it is fixed.

Hence, closing the issue as Verified.

Comment 8 Bryan Kearney 2015-08-12 16:04:42 UTC
This bug was fixed in Satellite 6.1.1 which was delivered on 12 August, 2015.