Bug 1244851 - vti tunnel does not work
Summary: vti tunnel does not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: iproute
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Phil Sutter
QA Contact: Jaroslav Aster
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-20 15:19 UTC by Jaroslav Aster
Modified: 2015-11-19 14:42 UTC (History)
0 users

Fixed In Version: iproute-3.10.0-50.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 14:42:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2117 normal SHIPPED_LIVE iproute bug fix and enhancement update 2015-11-19 11:35:06 UTC

Description Jaroslav Aster 2015-07-20 15:19:50 UTC
Description of problem:

Hi,

I tried to configure vti tunnel on current rhel-7, but iproute is not able to configure [io]key, it fails with error. If I try it without [io]key than interface is created, but tunnel does not work.


Version-Release number of selected component (if applicable):

iproute-3.10.0-46.el7


How reproducible:

100%

Steps to Reproduce:
1. with [io]key

# ip tunnel add Test mode vti remote 1.1.1.1 key 15
Keys are not allowed with ipip and sit tunnels


2. with key

A:

# ip tunnel add Test mode vti local 10.34.36.99 remote 10.34.59.74
# ip a add 172.29.1.1/24 dev Test
# ip l set dev Test up
# ip -d l show dev Test
55: Test@NONE: <POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN mode DEFAULT 
    link/ipip 10.34.36.99 peer 10.34.59.74 promiscuity 0 
    vti remote 10.34.59.74 local 10.34.36.99 ikey 0.0.0.0 okey 0.0.0.0 addrgenmode eui64

B:

# ip tunnel add Test mode vti remote 10.34.36.99 local 10.34.59.74
# ip addr add 172.29.1.2/24 dev Test
# ip l set dev Test up
56: Test@NONE: <POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN mode DEFAULT 
    link/ipip 10.34.59.74 peer 10.34.36.99 promiscuity 0 
    vti remote 10.34.36.99 local 10.34.59.74 ikey 0.0.0.0 okey 0.0.0.0 addrgenmode eui64

A:

# ping 172.29.1.2
PING 172.29.1.2 (172.29.1.2) 56(84) bytes of data.
From 172.29.1.1 icmp_seq=1 Destination Host Unreachable
From 172.29.1.1 icmp_seq=2 Destination Host Unreachable
From 172.29.1.1 icmp_seq=3 Destination Host Unreachable
^C
--- 172.29.1.2 ping statistics ---
3 packets transmitted, 0 received, +3 errors, 100% packet loss, time 1999ms

Actual results:

VTI does not work.

Expected results:

VTI works.

Additional info:

There is second issue, documentation. There is no mention about vti in ip-tunnel manpage.

Comment 1 Phil Sutter 2015-08-07 10:26:31 UTC
This issue is fixed upstream already, backport is straight forward.

Comment 6 errata-xmlrpc 2015-11-19 14:42:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2117.html


Note You need to log in before you can comment on or make changes to this bug.