Bug 1244916 - glibc segfaults immediately after chrooting into the stage2 bootstrap environment
glibc segfaults immediately after chrooting into the stage2 bootstrap environ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Carlos O'Donell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-bootstrap
  Show dependency treegraph
 
Reported: 2015-07-20 14:37 EDT by Jaromír Cápík
Modified: 2016-11-24 07:03 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-16 09:43:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaromír Cápík 2015-07-20 14:37:02 EDT
Description of problem:
During the stage2 bootstrap we experience glibc segfaults when chrooting into the minimal environment. The issue only happens for some combinations of builder and target architectures.

Since it's difficult to collect sufficient debug data, we offer an access to the build environment where we're able to reproduce the issue.

I tried to do a diff of the nm output for a working and non-working libc.so.* and both contain the same symbols. However they differ in addresses and that probably means the generated code differs.

Version-Release number of selected component (if applicable):
glibc-2.20-8.fc21
gcc-4.9.2-6.fc21
binutils-2.24-32.fc21

How reproducible:
always
Comment 1 Carlos O'Donell 2015-07-20 15:14:17 EDT
Arch? I think you saw this on aarch64?
Comment 2 Jaromír Cápík 2015-07-24 05:39:12 EDT
It applies to multiple architectures. aarch64 is just one of them. Right know I'm sure it's reproducible with all B=T rootfs except x86_64.
Comment 3 Jeff Law 2015-07-24 17:43:11 EDT
Adding DJ as we expect he'll be lending a hand on getting the bootstrapping process going.
Comment 4 DJ Delorie 2015-09-10 21:34:28 EDT
Turns out the root cause of this problem is this line in stage1's glibc recipe:

echo libc_cv_ctors_header=yes >> config.cache

Commenting out or removing that line should fix it.
Comment 5 Jaromír Cápík 2015-09-14 12:18:25 EDT
Thanks guys. Gonna try.
Comment 6 Jaromír Cápík 2015-09-16 09:43:41 EDT
Seems to work for all previously failing combinations. I couldn't test s390 due to an outage, but I believe it's ok too.

Thanks a lot for the fix.

Note You need to log in before you can comment on or make changes to this bug.